SAP Knowledge Base Article - Public

2803075 - Purge Inactive User: Soft and Permanent User Purge

Symptom

  • The purge of users fails even though the users have been made inactive in the system.
  • Is it possible to un-check the option 'User is active in a recruiting process' for the purging of inactive users?
  • Purge failed because the user is an operator for any of the statuses (open or pre-approved or closed) of the Job Requisitions (<JOREQID>)
  • Purge failed because the user is a U step user in requisitions (<JOREQID>)
  • Purge failed because the user is an active job offer approver for applications/requisition (<APPID>/<JOREQID>)
  • Purge failed because the user is an active interviewer for applications/requisitions ((<APPID>/<JOREQID>

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP Successfactors Recruiting Management

Reproducing the Issue

Soft Purge:

  1. Make the user inactive in the system
  2. Set up a purge rule in Data Retention Management
  3. Launch or schedule the purge rule
  4. Once this purge is approved in Purge Request Monitor, verify if the job has completed successfully. If the job has completed with errors, please open the file under "view results" to see why the user was not purged. 

Cause

For users to be processed by the RCM Purge tool, they must not fall under any of the scenarios mentioned below. If the user is still tied to a requisition, application or interview, they will not be purged from the system.

  • User is an operator for any of the statuses (open or pre-approved or closed) requisitions (<JOREQID>)
  • User is a U step user in requisitions (<JOREQID>)
  • User is an active job offer approver for applications/requisition (<APPID>/<JOREQID>)
  • User is an active interviewer for applications/requisitions ((<APPID>/<JOREQID>

Resolution

Please find a detailed description and steps for resolution for each of the scenarios below:

1. Operator

Error which appears in the report:

<USERID> is an operator for open or pre-approved or closed requisitions (<JOREQID>).

Reason for the error:

The user cannot be purged because this user is involved in a routing step workflow and a task was not completed. This means that the user is currently tied to a step in the route map.

If a user is the originator and:

  • the job requisition is currently with this user (typically the job requisition is in the first step).
  • has not yet reviewed the job requisition (less typical case when the originator is involved in a further step other than the first one and the job requisition did not reach this step).

If a user is a V role and has not yet reviewed the job requisition still on the pre-approve stage.
V role is one of the following cases:

  • Is an ad-hoc approver (added to the routing map by the “add approver” button)
  • is a derived role (like GM for example)
  • is a user with normal roles (like R or G) but involved in a Collaborative or Interactive step (C or I steps)

How to resolve it:

 Remove the user from that operator role.

a) From the job requisition detail page if the operator is editable

purge2.png

b) Go to Admin Centre --> Reassign Job Requisition--> Select the template name and job requisition id. Please note that since the B1902 release, an originator can also be reassigned.

purge3.png

NOTE: Product Support and Software Engineering teams have identified that if a User is associated as an Originator in Closed Job Requisition, the Purge may fail. This behavior should not be expected as Closed Job Requisitions should not be stopping Users from being purged, since there's no pending task related to a closed form. The behavior has already been addressed and Software Engineering is currently working on it. As for now, the solution would be reassigning a new User as Originator as already provided in the above steps.

You can also run a Report to identify how many Users with a scheduled Termination event are associated as Originators in Closed Job Requisitions. For more details, please refer to the KBA: 3249004 - Identifying Closed Job Requisition Originators with Scheduled Termination Events via Adhoc Report - Recruiting Management.

As a follow-up on the current status of the solution, please refer to your account manager the internal ticket - RCM-111093.

 2. U User

Error which appears in the report:

<USERID> is U step user in requisitions (<JOREQID>).

How to resolve it:

If the user is part of the U step (add additional approver or step defined as U step) AND the current step of the routing map is before or current step, then the user cannot be purged.

a) A way to resolve the problem is to move the job requisition over the U step, or eventually to approve completely the job req.

NOTE: to do this, you will need to re-activate the inactive user. However this is difficult if you also have Employee Central enabled.

Best practice when using both EC and RCM would be to move the user away from this step before inactivating the user.

3. Offer Approver

Error which appears in the report:

<USERID> is being an active job offer approver for applications/requisition (<APPID>/<JOREQID>).

How to resolve it

 a) If the offer is in draft (was not yet submitted for approval), it is enough to edit the offer and remove the name of the user.

purge4.png

b) Another way is to reassign the offer to another user by navigating to Admin Centre -> Reassign Offer Approvals

purge5.png

4. Interviewer

Error which appears in the report:

<USERID> is an active interviewer for applications/requisitions ((<APPID>/<JOREQID>).

Reason for the error:

If a user is an interviewer for one or more candidates, but there is at least one of these candidates which is not rated, the validation will give this error and will prevent the purge.

How to resolve it:

Go to the application page of the candidate in question and remove the inactive user from the list by clicking the "Set up Interviewers" button.

purge6.png

A pop up will appear and you will be able to  then delete the interviewer

purge7.png

Note: If the soft purge is completed successfully, then the permanent purge should not fail. If this is the case, please do not hesitate to create an case with support containing details of the failed purge.

There is currently no way to un-check the option 'User is active in a recruiting process' for the purging of inactive users. This option is hard coded in the system to be selected and there is no way to un-tick this option.

Keywords

KBA , LOD-SF-RCM-SYS , System Performance, Usability, Errors, Security , Problem

Product

SAP SuccessFactors Recruiting all versions