SAP Knowledge Base Article - Public

2803075 - Purge Inactive User: Soft and Permanent User Purge

Symptom

Why does the system does not allow to purge users even if they are marked as "Inactive"?

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP Successfactors Recruiting Management

Reproducing the Issue

Please see the information below:

Soft Purge:

  1. Make the user Inactive
  2. Set up a purge rule in Data Retention Management
  3. Launch or schedule the purge rule
  4. Once this purge is approved in Purge Request Monitor, verify if the job has been completed successfully. If the job is completed with errors, please open the file under "view results" to see why the user was not purged. 

Cause

For users to be processed by the RCM Purge tool, they must not be in any of the following scenarios:

  • is an operator for open or pre-approved requisitions (<JOREQID>)
  • is U step user in requisitions (<JOREQID>)
  • is being an active job offer approver for applications/requisition (<APPID>/<JOREQID>)
  • is an active interviewer for applications/requisitions ((<APPID>/<JOREQID>

Resolution

Please find a detailed description and steps for resolution for each of the scenatios below:

1. Operator

Error appearing in the log

<USERID> is an operator for open or pre-approved requisitions (<JOREQID>).

Reason for giving the error

The user cannot be purged because this user is involved in a routing step workflow and a task was not completed. This means that the user is currently involved in the current step of the routing map.

If a user is the originator and:

  • the job requisition is currently with this user (typically the job requisition is in the first step).
  • has not yet reviewed the job requisition (less typical case when O is involved in a further step other than the first one and the job requisition did not reach this step).

If a user is a V role and has not yet reviewed the job requisition still on the pre-approve stage.
V role is one of the following cases:

  • Is an ad-hoc approver (added to the routing map by the “add approver” button)
  • is a derived role (like GM for example)
  • is a user with normal roles (like R or G) but involved in a Collaborative or Interactive step (C or I steps)

How to resolve it:

 Remove the name from being that operator.

a) From the job requisition detail page if the operator is editable

purge2.png

b) Go to Admin Centre --> Reassign Job Requisition--> Select the template name and job requisition id. Please notice that since b1902, an originator can be reassigned.

purge3.png

 2. U User

Error appearing in the log

<USERID> is U step user in requisitions (<JOREQID>).

How to resolve it

If the user is part of the U step (add additional approver or step defined as U step) AND the current step of the routing map is before or current step, then the user cannot be purged.

a) A way to resolve the problem is to move the job requisition over the U step, or eventually to approve completely the job req.

NOTE: to do this it should be needed to re-activate the inactive user. However this is difficult in case of EC.

Best practice for EC and RCM : is before inactivating a user to move away from the step.

3. Offer Approver

 Error appearing in the log

<USERID> is being an active job offer approver for applications/requisition (<APPID>/<JOREQID>).

How to resolve it

 a) If the offer is in draft (was not yet submited for approval), it is enough to edit the offer and remove the name of the user.

purge4.png

b) Another way is reassigning the offer to another user via navigating to Admin Centre --> Reassign Offer Approval

purge5.png

4. Interviewer

Error appearing in the log

<USERID> is an active interviewer for applications/requisitions ((<APPID>/<JOREQID>).

Reason for giving the error

If a user is an interviewer for one or more candidates, but there is at least one of these candidates which is not rated, the validation will give this error and will prevent the purge.

How to resolve it

Go to the application page and remove the inactive user from the list by clicking "Set up Interviewes" button.

purge6.png

A pop up will appears and you will be able to delete the interviewer

purge7.png

Note: If the soft purge is completed successfully, then the permanent purge should not fail. If this is the case, please do not hesitate to create an incident with Support.

Keywords

user purge, soft, permanent, constraints. , KBA , LOD-SF-RCM-SYS , System Performance, Usability, Errors, Security , Problem

Product

SAP SuccessFactors Recruiting all versions