Symptom
- Failed to call SAP Analytics Cloud agent in SAP Analytics Cloud (SAC).
- http://localhost:8080/C4A_AGENT/deploymentInfo prompts for login and gives {"version":"1.0.<##>"}
- http://<HostName>:8080/C4A_AGENT/deploymentInfo gives HTTP Status 403 - Forbidden
Below error in SAP Analytics Cloud > System > Data Source Administration:
"Failed to call SAP Analytics Cloud agent. Please contact your administrator to ensure that SAP Analytics Cloud agent is running, is configured correctly, and is reachable from the SAP Cloud Platform Cloud Connector. HTTP Status: 403; PATH: /deplymentInfo"
Environment
SAP Analytics Cloud
Reproducing the Issue
- Configure SAP Analytics Cloud Agent per https://help.sap.com/doc/00f68c2e08b941f081002fd3691d86a7/release/en-US/7cb6ffb38c294a5c871d6cc6ad5b1b36.html
- Click "Check Configuration" and notice the error
Cause
Network proxy is blocking a request to <Hostname> on port 8080.
Resolution
NOTE: Please make sure the SAP Cloud Platform (SAPCP) cloud connector and SAP Analytics Cloud Agent have been configured correctly as mentioned in Help Guide without any minor spelling errors such as C4A_AGENT and not C4_AGENT as these could also lead to such errors.
If SAPCP Cloud Connector and Apache Tomcat hosting SAP Analytics Cloud Agent are on the same machine then use SAP Cloud Connector entries:
- Internal Host: localhost:8080
- Virtual Host: <Hostname>:8080
If SAPCP Cloud Connector and Apache Tomcat hosting SAP Analytics Cloud Agent are on different machines:
- Ask your network proxy administrator to allow a request to <Hostname> on port 8080
- Update the proxy settings on the SAP Cloud Connector machine to not use the proxy for requests starting with <Hostname>
See Also
- SAP Analytics Cloud data connectivity community topic page
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening an case for SAP Analytics Cloud?
- 2511489 - Troubleshooting performance issues in SAP Analytics Cloud
- Search for SAP Analytics Cloud content using Google or Bing:
- https://www.google.ca/search?q=site%3Ahttps%3A%2F%2Fapps.support.sap.com+SAP+Analytics+Cloud
- https://www.bing.com/search?q=site%3Ahttps%3A%2F%2Fapps.support.sap.com+SAP+Analytics+Cloud
- Note: Add relevant text or warning/error messages to the text search field to filter results.
- SAP Analytics Cloud > Learning > Data Connections
- SAP Analytics Cloud > Learning > Guided Playlists
- SAP Analytics Cloud > Learning > Guided Playlists > Getting Support
- Need More Help? Contact Support or visit the solution finder today!
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