Symptom
When trying to create a lead using an existing account and contact you get the error "Save failed
Last name missing".
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Sales work centre
- Go to the Leads view
- Create a new lead using and existing account which has an existing contact - the contact has a last name maintained in the master data (Contact TI).
Result: when trying to save, the system throws the error:
Save failed
Last name missing
Since we are using an existing contact, the contact has a last name maintained.
Cause
You might have a customization within which you are trying to edit the contact's master data.
In leads, if you're updating ANY master data field values for existing contacts you won't be allowed - those edits need to be executed on the actual master data (in the Contact object) - they cannot be updated from a transactional document such as lead.
>> that is not allowed for existing contacts - especially, if this is not the same as in Master Data.
An example could be, that you have a rule on one of the fields doing a determination, for example the address fields, language fields, etc..
Resolution
Remove such determination rules and check again. In standard, this error will not occur.
See Also
Keywords
Last name, missing, Lead, create, error , KBA , LOD-CRM-LM , Lead Management , How To