SAP Knowledge Base Article - Public

2718753 - The Error Message 'Last Name Missing' Triggered On Marketing Lead Creation

Symptom

The error message 'Last Name Missing' is triggered when saving a new Lead even though the field is not flagged as mandatory.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales work center.
  2. Go to the Leads view.
  3. Select the New button.
  4. Enter a value in all mandatory fields.
  5. Enter a value in the Contact Last Name field (Please note that this field is not mandatory).
  6. Select enter.
  7. Now remove this entry and select enter again.
  8. Select the Save button.
  9. The error message 'Last Name Missing' is triggered even though the field is not mandatory.

Cause

When you enter a value for the Contact last name and select the enter button, the Contact person is created for that Lead and also the Account/ Contact relationship has been created. When you then remove the Contact Last Name and select the enter button, the Contact with relationship to Account still exists.

Resolution

This is the expected system behaviour. If you want to create a Lead with an Account and do not want to create a Contact relevant for the Lead, you can just cancel the Lead and select the New button to create a new Lead again.

See Also

  • KBA 3104288 - Lead QC Error: "Save failed Last name missing"
  • KBA 2655023 - Contact Last Name Field Is Mandatory in Leads

Keywords

KBA , leads , 'last name missing' , mandatory , LOD-CRM-MKT-PRO , Prospect , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions