SAP Knowledge Base Article - Public

2933072 - Error We couldn't connect to your HANA system. Possible causes: Third-party cookies are blocked, or CORS is not configured correctly happens when creating live HANA connection in SAP Analytics Cloud (SAC)

Symptom

The following error occurs when configuring a HANA live connection in SAP Analytics Cloud (SAC):

  • We couldn't connect to your HANA system. Possible causes: Third-party cookies are blocked, or CORS is not configured correctly. For more information, see our troubleshooting page.

Environment

  • SAP Analytics Cloud (Enterprise)
  • SAP HANA HDI in SAP Cloud Platform Cloud Foundry (live)

Reproducing the Issue

  1. Configure SAP HANA HDI in SAP Cloud Platform Cloud Foundry (live).
  2. Create live HANA connection in both SAC system A and SAC system B using the same connection information.
  3. In SAC system A, the live HANA connection is working.
  4. In SAC system B, error below happens when creating the live HANA connection:

    We couldn't connect to your HANA system. Possible causes: Third-party cookies are blocked, or CORS is not configured correctly.
    For more information, see our troubleshooting page.

Cause

CORS: >
[
      {
               "uriPattern": "^/sap/bc/ina/(.*)$",
               "allowedOrigin": [
                                              {"host":"<orca-tenant-host>", "protocol":"https"}
                                       ],
               "allowedMethods": ["GET", "POST", "HEAD", "OPTIONS", "PUT", "DELETE"],
               "allowedHeaders": ["Origin", "Accept", "X-Requested-With", "Content-Type", "Access-Control-Request-Method", "Access-Control-Request-Headers", "Authorization", "X-Sap-Cid", "X-Csrf-Token"],
               "exposeHeaders": ["Accept", "Authorization", "X-Requested-With", "X-Sap-Cid", "Access-Control-Allow-Origin", "Access-Control-Allow-Credentials", "X-Csrf-Token", "Content-Type"]
      }

]

Resolution

Add the host of system B to the allowedOrigin part of YAML configuration file as well.

The format of multiple hosts is maintained as follows:

"allowedOrigin": [ {"host":"<host of your SAP Analytics Cloud tenant A>", "protocol":"https"},{"host":"<host of your SAP Analytics Cloud tenant B>", "protocol":"https"}]

Note: 
Chrome Incognito mode (or similar mode for other browsers) may block third-party cookies by default.
Please check the browser setting to allow all cookies if the user wants to use Incognito mode.

See Also

Your feedback is important to help us improve our knowledge base.

Keywords

SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, EPM-ODS, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics, HANA, live, service, third, party, cookies, CORS, fail, failed, create, connections,
SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, EPM-ODS, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics, "{" error ": {" code ": 11," message ":" ina: Parameter 'Request' is missing. "}}" appears. From SAC tenant url still unable to connect to the system. HANA Live Data Connection Create Model 403 Error, create model from live data connection, Enable SAML SSO for SAC with Live Connection to HANA on SCP, the Live Connection in SAC is broken with error message as "Protocol Error: Error [Protocol]: (#73) Error [Protocol]: (#403)"
SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics,Error, Issue, System, Data, User, Unable, Access, Connection, Sac, Connector, Live, Acquisition, Up, Set, setup, Model, BW, Connect, Story, Tenant, Import, Failed, Using, Working, SAML, SSO, sapanalyticscloud, sap analytical cloud, sap analytical cloud, SAC, sap analyst cloud, connected, failure, stopped, sap analyst cloud, https://hcs.cloud.saphttps://hanacloudservices.cloud.saphttps://cloudanalytics.accounts.ondemand.comhttps://hanacloudservices-us.accounts.ondemand.comhttps://www.sap.comhttps://help.sap.com, predictive analytics (analysis), data analysis (analytics) tools, analytics tools, sap analytics cloud, data literacy, advanced analytics, data democratization, analytics software, real time analytics, self service analytics, advanced data analytics, analytics as a service, analytics cloud / cloud analytics, saas analytics, cloud bi, enterprise planning, cloud data analytics, cloud based analytics, analytics cloud platform, modern analytics, real time analysis, cloud analytics solution(s), what is sap analytics cloud, cloud analytics tools, analytics in the cloud, cloud analytics software epm, business intelligence, , KBA , sac third-party cookies are blocked kba , saml sso not working for live data conne , for live data connection , LOD-ANA-LDC-HAN , SAC Live Data Connection HANA , Problem

Product

SAP Analytics Cloud 1.0