SAP Knowledge Base Article - Public

2900915 - IPS Job sync error - statusCode: 400, Response: Email for user creation not provided

Symptom

You've added SAP SuccessFactors as a source system and SAP Cloud Platform Identity Authentication/SAP Analytics Cloud as a target system.

After you start provisioning job you receive error:
"HTTP operation failed invoking  <system_URL> with statusCode: 400, Response: Email for user creation not provided

Environment

SAP Cloud Platform Identity Authentication
SAP Analytics Cloud
SAP SuccessFactors

Reproducing the Issue

1. Start provisioning job.
2. Job fails with error.
3. View the Job Logs to see the results.

Cause

The user e-mail is optional for SAP SuccessFactors (it might not be unique). However, it's mandatory and unique for Identity Authentication/SAP Analytics Cloud.
This error appears when the email mapping in source and/or target system transformation is incorrect.

Resolution



1. Check/Modify the email mapping in source system transformation (SAP SuccessFactors)

  • If all users have e-mails, which are unique, you can use transformation:
 {
"sourcePath": "$.email",
"targetPath": "$.emails[0].value", 
"correlationAttribute": true
},
  • If there are uses who have no e-mails or they are not unique, use transformation:
 {
"sourcePath": "$.userId",
"targetPath": "$.emails[0].value", 
"correlationAttribute": true, 
"functions": [
{
"function": "concatString",
"suffix": "@noemail.com"
}
]
},

Explanation: This way, each provisioned user will be created in Identity Authentication with a unique e-mail in format <userId>@noemail.com. Instead of noemail.com, you can use an actual domain name, or another non-existing one.

Cauion: By modifying the transformation, all users will be created in Identity Authentication with e-mail addresses of this format, even the ones whose e-mails are unique in SAP SuccessFactors. If you don't want to "lose" the original e-mails in Identity Authentication, we recommend that you manually edit email for the problematic users in the source system (SuccessFactors).


2. Check/Modify the email mapping in target system transformation:

  • If the target system is Identity Authentication, use transformation:
 {
"sourcePath": "$.emails[*].value",
"preserveArrayWithSingleElement": true,
"targetPath": "$.emails[?(@.value)]" 
},
  • If the target system is SAP Analytics Cloud, use transformation:
 {
"sourcePath": "$.emails",
"preserveArrayWithSingleElement": true,
"targetPath": "$.emails" 
},

{
"condition": "$.emails[0].length() > 0",
targetPath": "$.emails[0].primary",
"constant": true
},


3. Re-sync job

See Also

SAP Help Document: SAP Cloud Platform Identity AuthenticationSAP SuccessFactorsSAP Analytics Cloud

Guided Answers: Multiple Users from a Source System Are Created as One in the Target

Keywords

statusCode: 400, transformation, SuccessFactors, SAP Cloud Platform Identity Authentication, source, target, Email for user creation not provided, IPS, Identity Provisioning, job sync, error,  HTTP operation failed invoking, email, provisioning job, Job Log, SAP Analytics Cloud , KBA , BC-IAM-IPS , Identity Provisioning Service (IPS) , Problem

Product

SAP SuccessFactors HXM Core 1911