SAP Knowledge Base Article - Public

2899488 - CTI Call Simulation Not Working

Symptom

You notice that an inbound call does not work when using CTI Adapter in Cloud for Customer system, even though the configuration is done accordingly.

Environment

 SAP Cloud for Customer

Reproducing the Issue

  1. Open the CTI Adapter in your computer.
  2. Click Start Adapter.
  3. Click Simulate.
  4. Navigate to Cloud for Customer system.
  5. See the call is not received.

Cause

Depending on the browser used, the settings are set to "Not Allow" insecure content and the tenant URL myxxxxxx.crm.ondemand.com is not added to the browser trusted sites list.

Resolution

To correct this, follow the steps below:

Internet Explorer:

  1. Open Internet Explorer Browser.
  2. Click on the Cogwheel in the top-right corner.
  3. Click Internet Options.
  4. In the popup window, navigate to Security tab.
  5. Select Trusted Sites.
  6. Click Sites.
  7. Add the tenant URL.
  8. Click Add.
  9. Click Close.
  10. Click Apply.
  11. Click OK.

Google Chrome:

  1. Add the path chrome://settings/content/insecureContent in the chrome search bar.
  2. Click enter.
  3. In the Allow section, click Add.
  4. Add the tenant URL.
  5. Save the changes.
  6. Close and open the browser again.

You can also click on the red padlock which is shown near the tenant URL when the call is simulated on Chrome to easily allow the insecure content.

Keywords

CTI; Live Activity; Call; Calls; CTI Adapter; Simulate; Simulation; Inbound; Insecure; Browser; Content; Allow; Google Chrome; Internet Explorer; Service; , KBA , LOD-CRM-LA , Live Activity , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions