SAP Knowledge Base Article - Public

2894776 - Scheduled Offering Delivery Notification failed - Unable to parse the notification

Symptom

Scheduled Offering Delivery Notification APM has been failed due to the following error message:

com.plateausystems.elms.util.helper.ElmsCheckedException: com.plateausystems.elms.framework.notification.helper.NotificationException: Unable to parse the notification as the size(8738754) is beyond the allowed limit : 25 Mb

Environment

SAP SuccessFactors Learning

Cause

The error message means that the standard maximum size of the email is 25 MB. The batch size of the users being populated on the email exceeds 10000 users and has reached the maximum capacity of the email size. As per the system logic 8,738,133 is the maximum number of characters allowed in email. The error message describes that the allowed characters has been exceeded.

Resolution

The solution and the prevention for the issue is to reduce the batch size number of user to 5000 which will split the number of user and hence the size of the email. It will reduce the number of students information added to the email from 10000 to 5000.

Please follow the steps below about how to make this change in the system:

  1. Navigate to System Admin> Configuration> System Configuration> LMS_ADMIN configuration file.
  2. Search for apmJobSettings.TRNGEXPIRE.transactionCommitSize.
  3. Change the value from 10000 to 5000.

Keywords

scheduled offering, 25 MB, parse, notification, APM, unable, exceeded, apmJobSettings.TRNGEXPIRE.transactionCommitSize , KBA , LOD-SF-LMS-NOT , Notifications , LOD-SF-LMS-SCH , Scheduled Offerings , LOD-SF-LMS , Learning Management System , Problem

Product

SAP SuccessFactors Learning all versions