SAP Knowledge Base Article - Public

2889470 - Blocked Supplier Account Has Been Used

Symptom

You have blocked the supplier account ABC but you have noticed that this supplier has been used after the date it was blocked.

Environment

SAP Business ByDesign

Reproducing the Issue

You have blocked the supplier account ABC (ABC being the name of your supplier account).

Some time after, you have noticed this supplier account has been used in some supplier invoices after the date this supplier account was blocked.

Cause

There can be two reasons:

-1 When creating a manual supplier invoice, if a user forces the entry of a supplier ID that has been blocked (enter the supplier ID in the field + click enter), the system will give you a warning message such as:

"Ship-from location with ID ABC blocked"

"Party Payee with ID ABC"

This warning message will inform the user that the supplier ABC is blocked, but will not stop the creation of the supplier invoice with the supplier ABC.

-2 You might have a recurring invoice run that is still active:

  • Work center Supplier Invoicing.
  • Click the view Recurring Invoices.
  • Use the filter "Active Recurring Invoices".
  • Search supplier ABC.
  • Go to Invoice History Tab.
  • From here you might see that the system has kept on creating Supplier Invoices for the supplier ABC after the date on which this supplier was blocked. 
  • To stop the system to create new recurring supplier invoices with this blocked supplier, it is advised to click "Block" from this Recurring Invoice run.

Resolution

  • Blocking a supplier will not stop a forced entry of supplier account in a manual supplier invoice.
  • When blocking a supplier account, it is advised to check if any active recurring supplier invoice run is still active, and block it to avoid any unnecessary supplier invoices.

Keywords

Blocked Supplier Account, Recurring Invoice Run, Supplier Invoices , KBA , AP-SIP-SIV , Supplier Invoice , How To

Product

SAP Business ByDesign all versions