SAP Knowledge Base Article - Public

2884818 - Involved Parties are deleted after a Realignment Run

Symptom

You have updated Territories in an Account and you notice that Involved Parties are removed from the related Opportunity.

You have scoped that sales documents are not to be updated by a territory update.

Environment

SAP Sales Cloud

Reproducing the Issue

  1. Go to the Sales workcenter.
  2. Go to the Opportunities view.
  3. Open Opportunity ABC (ABC stands for a name of the Opportunity).
  4. Go to the Changes facet.

Result: you find that the Involved Parties Sales Unit and Seller have been deleted by Technical_User. This was right after the territory of the account has been updated by a realignment run.

Cause

The reason is not the territory realignment but another job that has been activated in BC scoping for Opportunities:

"Do you want to automatically re-determine opportunity parties based on changes to the account team of the account?" is active.

Party re-determination is then triggered upon changes to

•The territory team of territories

•The account team of accounts

•The territory assignment of accounts

Resolution

Please check the master data. The changes there triggered the job to realign the transactions. Depending on BC Finetuning for Involved Parties for Opportunities this might cause undesired changes, e.g. when the logon user is used to derive the Sales Unit, etc.

Due to the fact, that the job has been triggered by a technical user that is not assigned to any org unit, this caused the loss of the Sales Unit and as follow-up problem the loss of the Seller which depends on the Sales Unit.

To avoid this loss,  BC Finetuning for Involved Parties for Opportunities offers the column "Realignment". There, the parties can excluded from the realignment.

Please use this column for Sales Unit, Org data, Seller and maybe any other parties that shall not be touched.

Keywords

realignment, territory, involved parties, sales unit, seller, remove, delete , KBA , LOD-CRM-OPP , Opportunity Management , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions