SAP Knowledge Base Article - Public

2882991 - Export dataset issue in Multi Dataset adhoc report for arabic characters

Symptom

Arabic characters display well in report preview but when dataset is exported in the multidataset ad hoc report the Arabic characters will display as question marks????.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors HCM Suite

  • Analytics & Reporting(Ad Hoc, YouCalc, ORD)

                 Ad hoc Reports & Report Builder

Reproducing the Issue

  1. Log in into instance from any of the Browsers
  2. Click Reporting
  3. Edit any Multi Data set ad hoc report which has Arabic characters in any of the field values and
  4. Export Dataset from "Data sets" as shown below

Export_data_set_MultiDataset.PNG]

    5. In the output file, we can see data for Arabic characters display as????

Export_dataset_in_En_debug (1).PNG

Resolution

Internal ticket number (for reference and can be access by SAP employees only): AYT-25275

Interim Workaround:
A possible workaround would be to output a single domain report, which exports as expected. Then merge the output into the output from the exported multi-dataset.

Keywords

Export, Dataset, Issue, Multi, Data, Sets, Ad hoc, Report, Arabic, Characters, Field, Values, Reporting, Output, Displays, Report, Builder , KBA , LOD-SF-ANA-ADH , Adhoc Reports & Report Builder , Bug Filed

Product

SAP SuccessFactors HXM Suite all versions