SAP Knowledge Base Article - Public

2882249 - Purge email notification empty or error to import new user under Import Background Data

Symptom

  • You have purged some users successfully and into the notification message the UserIDs or AssignmentIDs are not informed (message body is empty);
  • You have tried to import new users using the Import Background Data and the message error is being shown: You entered a user ID and assignment ID that do not match. Please use the assignment ID that corresponds to the user ID.

Environment

  • SAP SuccessFactors HXM Suite
  • SAP SucessFactors Employee Central

Cause

Users affected were import into the system using Add New Employee and EMP_EMPLOYMENT_INFO table is null.

Resolution

This is known issue and Engineering Team is planning to permanently fix on next release (b2005). As a workaround, customers could open a case with Support asking to fix users affected:

To customers that are facing the e-mail notification empty:

Component: LOD-SF-PLT-DRM

CompanyID:

Your written approval to run a script to fix those users:

To customers that are unable to import new users using Import Background Data:

Remove "^AssignmentId" column from the import file or set blank for all users who were hired after Oct 1, 2019 (Sep 18, 2019 exactly). If you still face issue, open an incident under LOD-SF-EC component

Keywords

email blank, assignment ID issue, error to import, cannot import user , KBA , LOD-SF-PLT-DRM , Data Retention Management , LOD-SF-EC , Employee Central , Problem

Product

SAP SuccessFactors HXM Suite all versions