SAP Knowledge Base Article - Public

2847690 - Change Opportunity Document Type After An Opportunity Is Created

Symptom

Change the opportunity processing type after an opportunity is created.

Environment

SAP Cloud For Customer

Reproducing the Issue

Prerequisite: System has existing Two Opportunity Document type  OPPT and ZOPT, where OPPT represents Standard Opportunity Document Type  and ZOPT represents the Custom configured Document type.

  1. Login to Fiori.
  2. Navigate to Sales Work Center.
  3. Go to Opportunities Work Center View.
  4. Click on New.
  5. Select Standard Opportunity Document Type OPPT to create new opportunity.
  6. Click on Save.
  7. Opportunity XYZ is created, where XYZ represents the Opportunity ID.
  8. Edit Opportunity XYZ to change the opportunity document type OPPT to another Opportunity Document Type ZOPT, where ZOPT is another opportunity document type.

Opportunity Document type OPPT of an opportunity XYZ once saved, cannot be changed to Other Opportunity Document Type ZOPT within tenant.

Cause

Changing the Opportunity document type (OPPT) once saved, cannot be changed into another opportunity document type (ZOPT), within a tenant. Here OPPT and ZOPT represents Opportunity Document Types within a tenant.

Resolution

An Opportunity, once saved using specific Document Type, cannot be changed to another Opportunity Document Type. This is an expected behaviour

Keywords

Change, Opportunity, Document Type, Saved Opportunity , KBA , LOD-CRM-OPP , Opportunity Management , Problem

Product

SAP Cloud for Customer add-ins all versions