SAP Knowledge Base Article - Public

2845539 - Some fields in the application are not visible to the applicant and/or the operators - Recruiting Management

Symptom

Some fields in application are not visible to the candidate applying and/or the operators of the job requisition, although the permission is correctly configured in the application/job requisition template.

Environment

SAP SuccessFactors Recruiting Management

Cause

There are many possible causes. One of them is:

No country is configured in the job requisition. The fields in application are configured as public="false" and an override is configured to set it to public="true". However, the overrides are dependent of the field country in the job requisition. Since there isn't any countries configured, the fields are not showing up.

Resolution

For this case, there are a few options:

  • If you have the permissions to see and edit this field, manually edit it through the Job Requisition Details page;
  • If you don't have the permissions to see this field, you might want to consider with your team if someone can have the permission to change it in the template, then manually change it;
  • Change it using SFAPI.

Keywords

country, application, fields, field, not visible, can't see, not showing, not filled, multi, stage, multistage, multi-stage, permission. , KBA , LOD-SF-RCM , Recruiting Management , Problem

Product

SAP SuccessFactors Recruiting all versions