SAP Knowledge Base Article - Public

2845528 - Searching for fields added to the Candidate Profile Extension does not return any data - RCM

Symptom

When a user search for fields from candiadte profile extension, it does not return any data or returns less results than expected.

The candidate profile extension has data but searching for the exactly term does not return anything.

CPE 1.png

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SuccessFactors Recruiting Management (RCM) - All versions

Reproducing the Issue

  1. Create a candidate manually and add information to the Candidate Profile Extension
  2. Go to Recruiting > Candidate Search
  3. Select the Profile Extension > Field which information was added in step 1
  4. Hit Search
  5. No candidadte is returned or less records than expected

Cause

This is a knonw issue and a code fix has been developed to resolve this problem.

Resolution

As of now, we have a workaroud in case you are creating a candidate manually.

Woraround:

You can add a manual candidate, add all the necessary information to the candidate profile FIRST, save it. Just after finishing the candidate profile changes you add the necessary information to the Candidate Profile Extension, if you follow these steps, the candidate will be searchable in the Profile Extension search.

If you are using an API to create the candidate and add information to the Profile Extension, we do not have any possible workaround.

The code fix will be implemented within the next system release 2019Q4.

 

See Also

 

2587869 Candidate Profile Extension - Recruiting Management

Keywords

RCM-67195 , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , Problem

Product

SAP SuccessFactors Recruiting all versions