SAP Knowledge Base Article - Public

2842008 - Phone number cut off when trying to call an employee from inside the mobile app - SAP SuccessFactors Mobile

Symptom

  • When clicking on the phone icon in the mobile app, the phone number is cut off
  • When trying to call an employee from inside the mobile app, the phone icon/dial button does not work

Environment

  • SAP SuccessFactors HCM Suite
  • SAP SuccessFactors Mobile

Reproducing the Issue

  1. Log in the mobile app
  2. Access the profile of any user
  3. Click on their phone number or on the phone icon right next to the phone number
  4. Nothing happens, or you are redirected to the telephone app with an incomplete/invalid phone number 

Cause

Special characters (such as slashes) on the phone number format may cause the system to cut off the number.

Resolution

Edit the user record and remove the special character from the phone number, or replace it with a supported character (such as dashes).

For example, if you have +11211/123456, change it to +11211123456 on user's profile.

Keywords

mobile app, app, sf app, phone, phone number, dial, phone icon , KBA , LOD-SF-FWK-MOB , Mobile Application , Problem

Product

SAP SuccessFactors HXM Suite all versions