SAP Knowledge Base Article - Public

2829856 - Custom Token in Offer Letter is Not Getting Resolved - Recruiting Management

Symptom

Custom Token in Offer Letter is not getting populated while sending to candidate email.

Environment

SAP SuccessFactors Recruiting Management - All Versions

  • Offer Letter

Reproducing the Issue

  1. After the Offer Detail step, create an Offer Letter
  2. Select the Offer Letter template
  3. Click in Preview button and notice the token is not getting resolved

Cause

If you had created a custom token of a custom field in the Offer Detail Template, which field information is coming from the Job Application Template or Job Requisition Template, the token will not populate, if this field has not been made as "Reportable". In the way the system is designed, only custom fields that are made as "Reportable" will resolve the value into an Offer Detail token, since only "Reportable" custom fields can be edited in the Offer Approval step.

Resolution

To resolve the value into the Offer Detail token, you must make the field reportable in Provisioning. Please, refer to the KBA 2081508 on how to make a custom field reportable. In case you would not like to make the field reportable, you must use a token to pull the field value from the previous source, like Job Application Template or the Job Requisition Template.

See Also

2823512 - How are Standard and Custom fields permissioned as read or write in the Offer Detail template

2081508 - Custom Reportable Recruiting Fields - Recruiting Management

Keywords

Token not resolving; Token Issue; Missing information in token; Custom token not working; , KBA , LOD-SF-RCM-CAO , Candidate Offers, Offer Letters , Problem

Product

SAP SuccessFactors Recruiting all versions