SAP Knowledge Base Article - Public

2829856 - Token in Offer Letter is Not Getting Resolved - Recruiting Management

Symptom

Token in Offer Letter is not getting populated while sending to candidate email.

Environment

SAP SuccessFactors Recruiting Management - All Versions

  • Offer Letter

Reproducing the Issue

  1. After the Offer Detail step, create an Offer Letter
  2. Select the Offer Letter template
  3. Click in Preview button and notice the token is not getting resolved

Cause

Essentially, if the information was properly filled in the place where the token is pulling the data, so the issue will be related to the Offer Detail step, where the information is being re-entered, but the token is still pulling the data from the previous location, not from the Offer Detail template. For example, if a custom token is pulling a value from a field in the Application Template and this same field is mapped in the Offer Detail template, then edited in the Offer Detail step, the token will not resolve, because a new value was entered.

Resolution

If the value is being edit in the Offer Detail step, the token should pull the data from the Offer Detail template, rather than the original source, like e.g., Job Requisition, Application.

See Also

2823512 - How are Standard and Custom fields permissioned as read or write in the Offer Detail template

Keywords

Token not resolving; Token Issue; Missing information in token; Custom token not working; , KBA , LOD-SF-RCM-CAO , Candidate Offers, Offer Letters , Problem

Product

SAP SuccessFactors Recruiting all versions