SAP Knowledge Base Article - Public

2822472 - Instructions on How to use a BADI to Manage the Communication Actions in E-Mail

Symptom

This document explains how you can use a custom BADI to enable or disable all reply options such as: Reply, Forward, or Reply with Outlook in the Ticket Interactions. Additionally, you can set the To Address by using this BADI you can set a default address as Sender of the email.

Further details about this feature here.

Environment

SAP Cloud for Customer

Cause

To achieve these settings you will need to enhance the standard C4C using a BADI via the SDK software.

Resolution

The BADI below is the one that must be activated to use this feature.

Once you activate it the changes will be applied to both (HTML5 and FIORI) UI's.

BADI.png

Keywords

BADI; E-mail; Communication; Interaction; , KBA , LOD-CRM-SRP , Service Request Processing , How To

Product

SAP Cloud for Customer core applications all versions