SAP Knowledge Base Article - Public

2821611 - Country Code Area from the Phone Number Field Cannot be Edited - Recruiting Management

Symptom

  • Country Code special area in Phone Number field is greyd out and can't be edited.
  • Is there a way to remove the gray area/country code information from the Phone Number field? 

External Candidate Profile:

2019-07-30_14-09-22.png

Internal Candidate Profile:

2019-07-30_14-20-09.png

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Recruiting Management - All Versions

Reproducing the Issue

  • External Candidate Profile
  1. Login in the external career site
  2. Go to Profile Information
  3. Check the Phone Field
  • Internal Candidate Profile
  1. Go to Careers
  2. My Candidate Profile
  3. Check the Phone Field

Cause

The standard field id="cellPhone" will have the country code area if Short Message Service (SMS) functionality is enabled. To populated special area, you must configure the standard field id="phoneCountryCode". Then when selecting the country code information, the code number will be automatically populated inside the code area in the Phone field and if the field id="phoneCountryCode" is not configured, the field can't be populated manually.

2019-07-30_14-31-02.png

2019-07-30_14-22-13.png

Resolution

With Short Message Service (SMS) enabled, the country code area will only be populated by the country code field, therefore the field should be configured if you would like to have the functionality.

See Also

2802316 - Candidate Profile "phoneCountryCode" field is not visible

2336022 - How to Enable SMS Interview Notifications

Keywords

Country Code Area; Country Code Field; Country Code Greyed Out; , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , Problem

Product

SAP SuccessFactors Recruiting all versions