SAP Knowledge Base Article - Public

2819306 - Error in unassociated E-mails "Inconsistent channel address in custom/envelope-from header in mime"

Symptom

Incoming e-mail received in Unassociated e-mails view with a Reason "Inconsistent channel address in custom/envelope-from header in mime" or "No matching contacts were found". You expect that those emails were linked to a Ticket or to a Default Account.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Service Work Center
  2. Go to Unassociated E-mail view
  3. You will see an email with the above mentioned Reason

Cause

"Handle multiple e-mail channel in TO address" feature is active in the system. If this is set the system will ignore the original header and consider only the ones added after the Mime. If the Mime is blank, the emails will arrive at the Unassociated queue.

Resolution

Solution 1:

If you want to keep this feature active, then it is very important to maintain the channel address in the TO/CC field along with the custom header or envelope-from attribute in the e-mail header and this needs to be done from your IT Team

Solution 2:

If you do not want to activate this feature, follow the below steps:

  1. Go to Administrator Work Center
  2. Go to Service and Social view
  3. Click on Ticket Configuration
  4. Select "No" option under "Handle multiple e-mail channel in TO address"
  5. Save and Close

Keywords

Multiple email, channel, custom,envelope-from, ticket, unassociated email , KBA , custom , envelope-from , LOD-CRM-SC-EML , Email , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions