SAP Knowledge Base Article - Public

2807352 - Instance Sync getting error pop up "Bad String"

Symptom

When you Access the Instance Sync tool and try to create a new Sync, you face an error with a pop-up saying "Bad String".

Environment

SAP SuccessFactors HCM Suite

Reproducing the Issue

  1. Login into the instance;
  2. Go to Instance Sync Wizard;
  3. Select Configuration Copy (Instance Synchronization) and click Next;
  4. Click on go through the Instance Synchronization Wizard tool from the beginning link if you have already started a sync before;
  5. You will face the pop with the error message "Bad String".

Cause

The cause is a database inconsistency on the link between instances, most likely due to some instance that it was linked be deactivated.

Resolution

The solution of the issue is to run a script to clear the database inconsistency.

You need to engage with Product Support by raising an incident to component LOD-SF-PLT-SYN.

We will open an internal incident with our engineering team for them to investigate the issue.

With their investigation, they will create a script to be run by operations team to solve the issue.

(For SAP internal reference, it can be referred to Jira TLS-12280)

Keywords

BizX , KBA , LOD-SF-PLT-SYN , Instance Synch , LOD-SF-PLT , Foundational Capabilities & Tools , Problem

Product

SAP SuccessFactors HCM Suite all versions