SAP Knowledge Base Article - Public

2795162 - Addressability check: in Target Group returns "For X members e-mail address is invalid" despite vaild e-mail address

Symptom

You are executing an Addressability check in a Target Group and receive the message "For X members e-mail address is invalid"; when you check the e-mail address, it is a valid address which can be contacted without bouncing.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales Campaign workcenter.
  2. Go to the Target Group view.
  3. Open any Target Group.
  4. Go to the Members facet.
  5. Click More > Check Email address. This returns the message "For X members e-mail address is invalid".
  6. Find the contact ABC (ABC stands for the contact name) this message refers to and open it.

Result: the e-mail address is valid.

Cause

For the contact ABC, the tickbox "E-Mail Invalid" is set to true.

Resolution

Please untick the box for the field "E-Mail Invalid"; the field might be hidden from the layout and you have to unhide it via Adaptation Mode.

Keywords

email invalid, e-mail, target group, check e-mail address, member, contact , KBA , LOD-CRM-MKT-TG , Target Groups , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions