SAP Knowledge Base Article - Public

2792572 - Workflow Rule with Timing Scheduled Does Not Have Option for Notification Action

Symptom

You are creating a workflow rule with timing equal to scheduled, but when navigating to the Step 3, Define Actions, you cannot find the option Notification.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Administrator work center.
  2. Select the Workflow Rules option.
  3. Click on New.
  4. On Steps 1, Enter Basic Data, select Timing as Scheduled.
  5. Click on Next until you reach Step 3, Define Actions.
  6. See that on the dropdown for Rule Type, you do not have the option Notification.

Cause

The Notification rule type contains its own method of scheudling and timing. You can use the timing of the rule as On Every Save on the Step 1, Enter Basic Data, and then control when the Notification will be sent on the Step 3, Define Actions.

Resolution

This is the expected system behaviors. For Notifications, the method of controlling timing is slighlty different.

If you need this changed urgently you may contact your implementation manager to help with such request or approach directly the SAP Cloud Service Center.

You can find more details about the services offered by Cloud Service Center . You can contact Cloud Service Center as follows:

  1. If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder
  2. If you are a customer: please use the little blue box “Contact Us” shown on the very right hand side of SAP Application Development site , choose “Contact Us”, choose “Services”, choose “SAP Custom Development” and complete the page.

Note: The services of the SAP Cloud Service Center will be charged as packaged services based on fixed prices.

An alternative option may be to check the SAP Customer Influencer Site to submit an idea.

Keywords

KBA , LOD-CRM-SRP , Service Request Processing , How To

Product

SAP Cloud for Customer add-ins all versions