SAP Knowledge Base Article - Public

2791468 - Instance Refresh Tool

Symptom

  • How to enable the Instance Refresh Tool for my Instance 
  • Setting Permissions for Instance Refresh Tool
  • Accessing the Instance Refresh Tool
  • Pairing the Instances
  • Creating an Instance Refresh Request
  • Monitoring instance refresh Tool 

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors HCM Suite

Cause

SuccessFactors team will execute pre-qualification criteria check on your pair of instances for enablement of the Instance Refresh self-service tool. If all pre-qualification criteria are met, tool will be enabled, and you will be notified. If your instances do not qualify to enabling the tool, we will proceed with manual refresh process and notify you of the schedule.

Resolution

How to enable the Instance Refresh Tool for my instance?

To enable the Tool create a BCP support ticket for refresh under the component LOD-SF-SER-REF. Just like manual refresh requests, you need to specify the source and target instances that you want to refresh and complete the Instance Refresh Form.

The instance refresh Tool does not support cross DC refreshes at this time for example DC2 to DC4 etc

For more information on requesting instance refresh, see KBA 2088117 - Instance: New Instance Creation, Test Instance, Instance Refresh, Clone - Platform.

Instance Refresh Tool is still in BETA. If your instances qualify to use the refresh self-service tool, going forward you should be using this tool to refresh your target instances. BCP ticket will guide you through the next steps. If your instances do not qualify to use the tool, we will proceed with the older refresh offering.

How to use the Instance Refresh tool?

Successfactors Application now allows you to create, monitor and cancel the schedule of your refresh requests directly from the admin center in a few easy steps.

Here is a quick video showing how to set up Role base permissions & to schedule the refresh : 

Warning : Ensure the username/userid you are using to schedule the refresh has less than twenty (20) characters

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NOTE: You can find the overall status of the instance refresh request, under the Refresh Status column reference Monitoring Instance Refresh Monitor Instance Refresh Tool

For more details on the Instance Refresh Tool please refer to the SAP help Document - Instance Refresh Guide

Consideration Post Refresh :

As part of the Instance refresh process scheduled jobs will get restored Automatically in the Target Instance eg. Username, Filename , Password.

The job owner will also get restored post refresh which means if the job owner no longer exists in the Newly refreshed instance the job will fail with "Invalid job owner" .

Frequently asked questions (FAQs) 

Question: What if the refresh status fails or is showing a reverted status?
Answer: If the status of your refresh is showing Failed or Reverted please Please contact SAP Cloud Support with the error log file. To download the log file, click the ellipses button under the Action column for the corresponding refresh request and then click "Download Log". For more details on status of your refresh please review SAP help Link here .

Question: What if the refresh completes with warnings ?
Answer: If the status of your refresh shows completed with warning you can still log in to the updated target instance and continue with other scheduled activities and testing. There may be some actions from SAP Cloud Support or customer side. See full list of warning messages and actions on KBA 2812823 - Refresh Status Information - Completed with warning - Full List

Question: You receive the following error : "The application encountered an unknown error". How do i fix the error ?
Answer: If you encounter an unknown error when pairing the tool KBA 2789795 - "Instance Refresh / Instance Sync Tool: The Application Encountered an Unknown Error" to resolve the error.

Question : Is this tool available now?
Answer: Yes, if you want to have this enabled please open Support ticket with LOD-SF-SER-REF so they can validate and enable it if all criteria is met.

Question: Not able to view 'Instance Refresh Center'. Is this new functionality available in Q1 release (could see Instance synchronization wizard).
Answer: As it is not GA till now, so To enable instance refresh tool, you need to raise a support ticket see KBA Instance Management

Question: If you schedule a refresh a month ahead, can it be canceled UP To the start of the refresh procedure?
Answer : Yes. it can be canceled before the start of refresh.

Question : Can we make certain sensitive data field scrambled?
Answer: Currently this is not supported by the refresh however Data Scrambling will be introduced in a future release.

Question: Is this tool handling also the Provisioning post-refresh configurations and integrations re-establishment?
Answer: Yes

Question: Can the refresh start on working business hours?
Answer : The refresh will be scheduled at non-working hours. The same time should be displayed there.

Question: Onboarding module is included on the Refresh?
Answer : No, Please submit a incident to the module onboarding to request this type of refresh.

Question : Schedule dates will need to take into consideration local time or DC time?
Answer: The date shown in the tool will be converted and shown according to the browser time zone.

Question : Is the refresh scheduled time also shown in the interface besides the selected Refresh scheduled date ? So we can see for how late the refresh is scheduled. Especially if there is a down-time of the target instance.
Answer : Yes, the scheduled date will be shown in the Overview page in the tool.

Question:  Can we cancel the refresh.
Answer : Once a refresh is in progress, it can't be canceled.

Question : Can we do email masking ?
Answer: The Recruiting Candidate Email Addresses and the Employee Profile Email Addresses can be masked.

Question: In the validation failed status was the refresh actually done? was it useful? in what kind of scenario system shows this kind of status?
Answer : The refresh is not done, if it is in 'Validation Failed' status. This status might pop-up, if the desired space is not available in the system, or if Instance Refresh was disabled in the target instance for some reason.

Question: Are Custom Themes copied from the Source to the Target instance after a refresh?
Answer: Yes. Custom Themes are copied as part of the refresh however the "Default" and "Visible" to theming data is not copied as part of the refresh see screen shot below: (Default/Visible to needs to be re-configured post refresh)

theme.png

Question: Is it possible to use the Instance Refresh tool for cross-datacenter instances?
Answer : The tool currently does not allow to select a different data center for the target environment.

Keywords

Instance Refresh Tool , IRT , Refresh , refresh , clone , BETA , Instance refresh BETA , How to enable the instance refresh tool , Instance refresh form , form , Instance Refresh , instance refresh , refresh , Failed , failed refresh , Reverted , reverted refresh , reverted , The application encountered an unknown error , The Application Encountered an Unknown Error
, KBA , LOD-SF-SER-REF , Instance Refresh , LOD-SF-PLT , Foundational Capabilities & Tools , Problem

Product

SAP SuccessFactors HCM Suite all versions

Attachments

IRT_BizX_Instance_Refresh Request Form__b1905.docx