SAP Knowledge Base Article - Public

2791280 - Joining "EmployeePayrollRunResultsItems" delivers blank records in advanced Reporting

Symptom

When joining EmployeePayrollRunResultsItems to EmployeePayrollRunResults (via "Payroll Relationship Employeepayrollrunresults Employeepayrollrunresultsitems") we do not see any data load up for Employeepayrollrunresultsitems table. It remains blank while EmployeePayrollRunResults pulls out data.

It can easily be reproduced by creating a new query in the "Payroll" realm. Just use the only available anchor EmployeePayrollRunResults, join any field of Employeepayrollrunresultsitems and click at preview. notice the fields from EmployeePayrollRunResultsitems table is blank

Environment

  • SAP SuccessFactors BizX Reporting
  • Advanced Reporting
  • Realms

Reproducing the Issue

  1. Login To the Instance > Analytics > Advanced Reporting
  2. Select the Object Payroll Information
  3. Drag and Drop the Object EmployeePayrollRunResults and notice data shows up
  4. Now Join EmployeePayrollRunResultItems and notice every field from the Child object is blank.
  5. Date options are set to current date (Since both the objects are effective dated)
  6. Verify on data in manage data section first.

Cause

Cause of the issue is few missing Metadata View definition with respect to this Object.

Resolution

Our Development team had identified the issue and this is planned to fix on 1908 (Quarter3 release of 2019)

Keywords

EmployeePayrollRunResults , EmployeePayrollRunResultItems , Payroll Information , KBA , LOD-SF-ANA-ODS , Advanced Reporting , LOD-SF-ANA , Analytics & Reporting (Ad Hoc, ORD) , Bug Filed

Product

SAP SuccessFactors HCM Core 1902