SAP Knowledge Base Article - Public

2790494 - Instance Sync error: "Unable to map the following permission to target instance permission: [PermissionSpec {permType='****', permStringValue='****'} ]" - SuccessFactors Platform

Symptom

When trying to perform an instance sync for a Permission Role (RBP), the following error occurs: "Unable to map the following permission to target instance permission: [PermissionSpec  {permType='****', permStringValue='****'} ]"

Environment

SAP SuccessFactors HCM Suite

Reproducing the Issue

  1. Create an instance sync request for a Permission Role (RBP) artifact
  2. On the Instance Synchronization Monitor, the sync request is shown with a failed status
  3. When opening the sync report for details, the following error message is displayed:  "Unable to map the following permission to target instance permission: [PermissionSpec  {permType='****', permStringValue='****'} ]"

Cause

The error presented indicates that one or more permissions in the source role are not available on the target instance, hence, they cannot be synced.

Resolution

Please review all permissions in the source role and validate which permissions are not available on the target instance. Then, please change the related configuration so as to enable those permissions on the target side and, after that, perform the sync again.

In some special cases, even if the permissions are available in the target RBP, there is still no way for them to be synced from source to target as they contain a business sequence number in the permission spec (permissions associated with a business sequence number means the permission is related to a form, report or template). The Instance Sync tool does not yet support that scenario, in which case you would need to manually perform the sync.

Currently, the system logs generated by that error scenario do not not indicate which permission caused the failure, so that customers must manually check that - neither the error message will contain that information nor Cloud Product Support will be able to retrieve it.

In order to have the enhancement of that log/error message considered within future development cycles, customers are highly encouraged to submit an enhancement request. That can be done on our Customer Influence Portal at https://influence.sap.com/successfactors. For detailed steps on how to raise an enhancement request, please follow KBA 2090228. All enhancement requests are reviewed by our Product Management team and, if successful, are developed and implemented in a future product release.

See Also

  • 2088055 - Instance Synchronization Feature Guide & need to know information - Platform
  • 2090228 - How to Submit Enhancement Requests for SAP SuccessFactors Products

Keywords

RBP Instance Sync, Instance Sync Error, synchronization error, RBP, artifact, unable to map, PLA-7641 , KBA , LOD-SF-PLT-SYN , Instance Synchronization , How To

Product

SAP SuccessFactors HCM Suite all versions