SAP Knowledge Base Article - Public

2789795 - Instance Refresh / Instance Sync Tool: The Application Encountered an Unknown Error

Symptom

You are getting "The application encountered an unknown error" message when you click on "Generate Token" on the Instance Pair Wizard window.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors HCM Suite

Reproducing the Issue

For Instance Refresh

  1. Go to Admin Center
  2. Look for Instance Refresh
  3. Once in the Instance Management landing page select Instance Refresh
  4. Click on Next
  5. Click on Create New Request button
  6. Click on Add New Pair
  7. Fill in the Target Details
  8. next screen clicks on Add New Pair
  9. Click on Generate Token button
  10. You receive the following error message: The application encountered an unknown error

Refresh.png

For Instance Synchronization

  1. Go to Admin Center
  2. Look for Instance Synchronization Wizard
  3. Click on Launch the Instance Synchronization Wizard
  4. Next screen clicks on Add New Pair
  5. Instance Pair Wizard pop-up
  6. Insert information required and click on Generate Token
  7. You receive the following error: The application encountered an unknown error

Capture2 (1).JPG

Cause

  • You are logged in SuccessFactors with an account whose userID has more than twenty (20) characters;
  • User do not have the Admin access to MDF OData API permission (located inside the Permission section Manage Metadata Framework of RBP);
  • Metadata Cache issue.

Resolution

There are two possible solutions for this scenario:

  1. You are logged in with an account whose userID has more than twenty (20) characters. Engineering Team reported that currently there is a limitation and they are expecting to have the final solution for this on the next SFSF b1908 release. As workaround please use any other account with less than twenty characters and perform the pairing process again. 

If this is not the case, please perform the following steps:

  1. Go to Admin Center > search for OData API Metadata Refresh and Export
  2. Perform a Refresh Metadata Cache (please follow the steps from KBA 2171588 - OData API Metadata Refresh and Export - SuccessFactors )
  3. After you perform the Refresh Metadata Cache please try to generate the token once again.

See Also

2605062 - Unable to find the target instance in the 'Configuration Sync Wizard' dropdown in the source instance

2171588 - OData API Metadata Refresh and Export - SuccessFactors

Keywords

The application encountered an unknown error - Instance Synchronization, Instance pair wizard, generate token error, Instance Refresh, Instance Sync tool , KBA , LOD-SF-PLT-SYN , Instance Synch , LOD-SF-SER-REF , Instance Refresh , Problem

Product

SAP SuccessFactors HCM Suite all versions