Symptom
- Custom SAML SSO has been enabled in SAP Analytics Cloud per Enabling a Custom SAML Identity Provider (IdP).
- E-mail addresses under Security > Users menu are overwritten with @unknown.org or @this-default-was-not-configured.invalid domain after the initial login since enabling custom SAML IdP.
- Example e-mail address given in the IdP: <example>@<examplecustomerdomain>.com
- E-mail after login: <example>@unknown.org or <example>@this-default-was-not-configured.invalid
Environment
- SAP Analytics Cloud
- Any Custom SAML 2.0 Identity Provider
- Cloud Foundry (non-SAP datacenter, AWS) eg. EU10, US10 etc.
Cause
- SAML Attribute mapping in the identity provider isn't configured properly.
- E-mail is not mapped/passed from custom IDP.
Resolution
Based on what datacenter SAC is running on please check solution in KBA 2519989.
- Perform the attribute mappings carefully, especially taking the case sensitivity into consideration.
- Make sure e-mail is mapped from custom IDP. (ADFS as sample below)
- Ensure that the attribute names match exactly (case-sensitive) with the same provided by the table in "Enable a Custom SAML Identity Provider" online guide.
-
For sample SAML attribute mapping in Azure IdP http://schemas.xxyzyz.org/ws/2005/05/identity/claims/email is not correct. It should be named and changed to email
- Please also make sure an additional SAML Attribute "Groups" is added with value "sac" as per Step 7 of the guide below -
- For more information please refer to - 2922448 - SAML Attribute Mapping in SAP Analytics Cloud (SAC) & SAP Digital Boardroom Master KBA
System Owner Role:
- If you are experiencing this issue with only the System Owner role, you will need to temporarily assign the System Owner role to another end user, and then log in once so that your email address is correctly updated.
- Please see KBA 2859509 - How to change the System Owner Email Address in SAP Analytics Cloud (SAC)
See Also
- 2411608 - SAP Analytics Cloud SAML authentication *** Master KBA ***
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening an case for SAP Analytics Cloud?
- Search for SAP Analytics Cloud content using Google or Bing:
- https://www.google.ca/search?q=site%3Ahttps%3A%2F%2Fapps.support.sap.com+SAP+Analytics+Cloud
- https://www.bing.com/search?q=site%3Ahttps%3A%2F%2Fapps.support.sap.com+SAP+Analytics+Cloud
- Note: Add relevant text or warning/error messages to the text search field to filter results.
- SAP Analytics Cloud > Learning > Data Connections
- SAP Analytics Cloud > Learning > Guided Playlists
- SAP Analytics Cloud > Learning > Guided Playlists > Getting Support
- Need More Help? Contact Support or visit the solution finder today!
Your feedback is important to help us improve our knowledge base.
Keywords
SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, EPM-ODS, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics , KBA , saml idp master kba sac , LOD-ANA , SAP Analytics Cloud (SAC) , LOD-ANA-BI , Business Intelligence Functionality, Analytic Models , LOD-ANA-PL , Planning , LOD-ANA-BR , SAC Boardroom , LOD-ANA-PR , SAC Predictive , Problem