SAP Knowledge Base Article - Public

2789125 - Extension Field Value is Not Retrieved When Querying Sales Orders via Webservice Even Though the Field is Marked as Available for Service

Symptom

Even though the Extension field is marked as Field Available for Service, you are not able to Query the value of an Extension Field in Sales Order using the QuerySalesOrder Webservice.

Environment

SAP Business ByDesign

Cause

You are using a wrong tag in the XML to extract the extension field value.

Resolution

You need to add the tag as mentioned below.

<n2:XYZ xmlns:n2="ABC">PQR</n2:XYZ>

XYZ represents the extension field name.

PQR represents the extension field value you wish to update.

ABC  represents the namespace, which is availble in the Further Usage screen.

Follow the below steps to find the namespace.

  1. Go to the Sales Orders work center.
  2. Go to the Sales Orders view.
  3. Open any Sales Order.
  4. Hover over Key User Settings and click Start Adaptation Mode.
  5. In the top-right of the screen, click on the button with your profile picture.
  6. Go into Adaptation Mode.
  7. In the side bar, scroll down until you see a plus ('+') sign.
  8. Click on it and select Extension Fields.
  9. Highlight the required extension field.
  10. Click on Further Usage.
  11. Go to the Services tab.

You can see the statement as mentioned below.

The namespace of the extension field is http://sap.com/xi/AP/CustomerExtension/BYD/*

See Also

2639826 - Extension Field Value is Not Retrieved When Querying Sales Orders via Webservice

Keywords

namespace wrong; namespace changed; , KBA , AP-SLO-SO , Sales Order , Problem

Product

SAP Business ByDesign all versions