SAP Knowledge Base Article - Public

2786330 - Query on User entity returns blank values - Integration Center

Symptom

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

You have made a query in Integration Center navigating to the User entity and some fields from it returned with blank values.

Example:
You start a query in the EmployeeTime entity and navigates to the User entity.

Some of the records related to the User entity appear as an empty value:

user_blank_1.jpg

Environment

SuccessFactors, Integration Center

Reproducing the Issue

  1. Create a new query in Integration Center
  2. Add a field that navigates to User entity
  3. Some of its fields returned with blank values

Cause

When a record from the User entity belongs to an inactive user, its data cannot be fetched through navigations. It will always be returned as an empty value.

Resolution

If the data from the inactive user is really needed, you'll have to start the query in the User entity itself, adding the filter to fetch inactive users (KBA 2324204).

Keywords

blank, empty, null, values, user, entity, integration center, successfactors, success, factors, navigation, export, userID, first name, last name, firstname, lastname, employeetime, employee, time , KBA , LOD-SF-INT , Integrations , LOD-SF-INT-INC , Integration Center , Problem

Product

SAP SuccessFactors HCM Core all versions ; SAP SuccessFactors HCM Suite all versions