SAP Knowledge Base Article - Public

2785866 - E-mail Viewer Tab Isn't Visible

Symptom

You perform layout adaptation and add the E-mail Viewer tab under e-mail activity, however the tab is not displayed.

Environment

SAP Cloud for Customer 1905 onward

Reproducing the Issue

  1. Go to the Activities work center.
  2. Go to the E-mails work view.
  3. Open the e-mail ID 123 (123 represents the ID).
  4. Click Adapt.
  5. Select Edit Master Layout option.
  6. Hover the mouse over the tabs location.
  7. Click Add Items and the Additional Tab pop-up will open.
  8. Select the E-mail Viewer and click Apply.

Result: The E-mail Viewer tab is not displayed as expected.

Cause

There can be several reasons:

  • The E-mail Viewer tab is not supportable in HTML5 UI and it will only work with Fiori UI.
  • The E-mail Viewer tab does not appear if the e-mail does not have HTML content available.
  • Only e-mails created and synchronized after 1905 have e-mail content stored.

Resolution

After the layout adaption, in case the e-mail has an HTML content, go to the Fiori UI.

It is currently not available for e-mails created via Tickets or Odata. -> This is planned to be made available from the 1908 release onward.

As of now this feature is only enabled for mail coming from Groupware and created via Accounts WC.

Keywords

E-mail Viewer, E-mail, Fiori UI, HTML5 , KBA , LOD-CRM-ACT , Activities , How To

Product

SAP C4C ADDINS 1905