SAP Knowledge Base Article - Public

2778907 - Unable to Change Passport Number for I9 Reverification [Compliance] - Onboarding 1.0

Symptom

When entering a new Passport Number an error is shown below when replacing the old number.

The following fields are required and must be filled in before you continue:

"Passport number does not match the number provided by new-hire previously"

Environment

SAP SuccessFactors Onboarding 1.0 - All Versions

Cause

The passport number would not be updated because employee’s foreign passport establishes identity and therefore does not require reverification.

Resolution

For Live Customer(s)

According to DHS: the I-94 establishes employment authorization and is the document which must be reverified.

Keywords

ONB-20182, I9 - Reverification, Onboarding, Passport Number, Passport number does not match the number provided by the new hire previously , KBA , LOD-SF-OBD-I9 , I9 Issues and requests for Onboarding , Problem

Product

SAP SuccessFactors Onboarding