SAP Knowledge Base Article - Public

2778315 - Power search provides duplicate records

Symptom

 When certain admins user the power search for a user name multiple records appear.

Environment

SAP SuccessFactors Learning Management System (LMS)

Reproducing the Issue

  1. Create an Admin in domain other than Public, i.e. domain1.
  2. Add a domain restriction to that admin in search user so that admin can view only users from domain1.
  3. Create a userID, i.e. testuser in domain1.
  4. Edit user and update any custom column value which contains same value as user id and some other strings, i.e. testuser test.
  5. Log on as admin created in step1, power search for the term user testuser.
  6. Multiple records will be displayed for the user type.

Cause

Due to code search results the score accounts for this custom column as a separate record.

Resolution

Code fix targeted for 1905 via LRN-54639

Workaround is to use the User menu search to account search; however issue is only a display issue and does not result in any functionality loss and records are linked to the same user.

Keywords

SAP Success Factors sf learning lms power search users duplicate records multiple results , KBA , LOD-SF-LMS-ADM , Admin Tools , LOD-SF-LMS , SuccessFactors Learning , Problem

Product

SAP SuccessFactors Learning 1808 ; SAP SuccessFactors Learning 1811 ; SAP SuccessFactors Learning 1902