SAP Knowledge Base Article - Public

2777238 - SF Learning Report Designer (a.k.a. Plateau Report Designer) Setup and Troubleshooting Tips

Symptom

  • This KBA will help resolve issues with configuring SF Learning Report Designer (a.k.a. Plateau Report Designer)
  • The following topics are covered:
  1. Installing SF Learning Report Designer
  2. Initial Report Designer Settings (Window → Preferences)
  3. Creating Workspace Shortcut and Originals Folder
  4. Creating an ApplicationResources.properties File
  5. Updating a System Report in Report Designer
  6. Add a New Data Object to a Report
  7. Joining Tables
  8. Concatenating Fields
  9. Translate Localized Fields
  10. Adding a Search Filter
  11. Updating the Library Image and Styles
  12. Binding Child Query to the Parent Query
  13. Proxy Server Settings (required for users that are behind a Proxy Server)
  14. Download Report Designer and find Data Source Connection Information
  15. Specify a separate JRE to use with SF Learning Report Designer

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Learning

Resolution

Installing SF Learning Report Designer (a.k.a. Plateau Report Designer) Video Tutorial Playlist

  1. Download the Report Designer directly from SuccessFactors Learning. Steps to download are on page 10 of this document. Click here to download a self-contained version of Report Designer 4.4.1.4 that includes JRE 7. There’s no installer, just unzip the file to your My Documents directory and double click PlateauReportDesigner.exe.
  2. When prompted by the installer, change the install path to My Documents (do not install Report Designer into the Program Files folder).
  3. Run the Report Designer under Start Menu → Plateau Report Designer → Plateau Report Designer.
  4. It is recommended to move the Report Designer panels to match the following screen shot. Add a panel, such as Properties, under Window → Show View.

ShowView.jpg

Note:

  • You will always open and modify reports that are exported from SF Learning. We will not create new custom reports under File → New.
  • Note: JRE 7 32 bit is required to run the latest version of SF Learning Report Designer. Do not use JRE 8. Refer to the end of this document if you cannot install JRE 7 on your computer.

Initial Report Designer Settings (Window → Preferences)

Data Set Editor → Set Number of rows to display to 10

 DSE D10.png

Data Set Editor → JDBC Data Set - Uncheck Prefetch all Schemas from database - Uncheck Enable SQL Code Assist - Set Maximum Number of Schemas to display to 1 - Set The time out limit to 15

JDBC.png

Preview → Data - Set Number of rows to display to 10

 Preview.png

Creating Workspace Shortcut and Originals Folder

  1. Navigate to My Documents/Plateau Report Designer
  2. Create a shortcut to the Workspace folder
  • Right-click the Workspace folder
  • While holding down the right button, drag the folder to the Desktop
  • Select Create shortcuts here (do not move the folder)
  1. Double click the Workspace folder shortcut.
  2. Verify the folder path is under the My Documents/Plateau Report Designer/Workspace 5. Create a new folder called originals in the Workspace directory. This folder will be used to back up the zipped report files that are exported from SF Learning.
  3. Create a new folder called originals in the Workspace directory. This folder will be used to back up the zipped report files that are exported from SF Learning 

Docuemnts.png

Creating an ApplicationResources.properties File

  1. Log into to SF Learning.
  2. Navigate to System Admin Tools Label Import/Export
  3. Select Export Labels
  4. Click Next
  5. Select Locale (Typically English)
  6. Click Next
  7. Click the add one or more from list link
  8. Click Add/Remove Criteria arrow
  9. Check Label Type ID
  10. Click Submit Query
  11. Enter LABEL into Label Type ID
  12. Click Search
  13. Check the Select all the labels of the search results checkbox
  14. Click Add (this may take a couple minutes)
  15. Click Next
  16. Enter PRD_Labels in the Export File textbox
  17. Click Download
  18. Move the text file to Report Designer Workspace
  19. Rename the text document to ApplicationResources.properties

 Updating a System Report in Report Designer

  1. Export Report from SF Learning
  2. Move the zip file to the workspace
  3. Unzip the report
  4. Rename the .rptdesign file
  5. Move the zip file to the originals folder
  6. Open the .rptdesign file in Report Designer
  7. Connect the DataSource to Database
  8. VJDBC Birt Wrapper Example (Your URL will be different)
  • Driver Class: de.simplicit.vjdbc.VirtualDriverBirtWrapper (v1.6)
  • URL: jdbc:vjdbc:servlet:https://staging.plateau.com/vjdbc/vjdbc,db10g
  • User: Admin ID in Staging with the REPORT_DEVELOPER Role
  • Password: Admin Password

      Preview the Report, scroll to the bottom, and check for errors  Make Changes

   9.  Preview

  1. Repeat steps 9 and 10 as necessary
  2. Remove any filters in the Master Query
  3. Preview/Save the report
  4. Select the Report Name in the Outline Panel and click the Zip icon
  5. Save the zip to the Workspace
  6. Import the zipped report into SF Learning
  7. Test the report in SF Learning
  8. Publishing an Admin Report
  9. Add the Custom Report Workflow to desired Admin Role
  10. Assign the Admin Role to desired Admins
  11. Click the (pencil icon) next to the Report, check Publish, and then click Save

 Add a New Data Object to a Report

  1.  Add a row or column for the new field
  2. Copy and paste a label into the new row/column
  • Select the new label
  • Go to Properties Editor panel
  • Select Localization
  • Click the Browse… button to select a new label value
  1. Find the Table Data Set
  •  Select the Table tab in bottom left corner of the Table
  •  Go to Properties Editor and select the Binding Tab
  •  Make a note of the Table Data Set name
  1. Under the Data Explorer Panel double click the Table Data Set, found in step 3, to open the query
  • Add the desired data object to the SQL
  • Preview the SQL and check for Errors
  • Click OK to save your changes
  1. Drag the new data object from the Data Explorer panel to the row/column that you created in Step 1
  2. Preview the Report

Joining Tables

  1.  Find the table that has the desired column
  2. Look for this table in the original query FROM clause. If it is already in thequery, skip to step 5
  3. Add the table to the FROM clause
  4. Join the table to the original query on the related column in the WHERE clause
  5. Select the desired column from the added table in the SELECT clause

Concatenating Fields

  1.  Right click an empty cell
  2.  Select Insert → Data
  3.  Enter a Column Binding Name and Display Name (e.g. UserName)
  4. Select a Data Type
  5. Click fx to open Expression Builder
  6. Select Available Data Sets under Categories
  7. Select the Data Set under Sub-Categories
  8. Double-click the fields and use + to concatenate (use double quotes for statictext), e.g.
  9. dataSetRow["LNAME"] + ", " + dataSetRow["FNAME"]
  10. Click OK
  11. Click OK
  12. Preview the report

Translate Localized Fields

  1. Double click the localized field that you added to the report
  2. Click fx to open Expression Builder
  3. Paste the following code:
     reportContext.getMessage(dataSetRow["CPNT_DESC"], reportContext.getLocale())
  4. Change CPNT_DESC to the localized field column name
  5. Click OK twice to save your changes
  6. Preview the report

Note: Localized fields are blank in the Report Designer Preview. They will
         populate when run in SF Learning.

Adding a Search Filter

  1. Find the desired Report Parameter in the Plateau Library
  2. Drag it into the Report Parameters under the Data Explorer Panel
  3. Open the Data Set(s) that you want to apply the filter
  4. Update the Plateau comment to include the new Report Parameter
    Note: Make sure the security line is the last line of the Plateau Comment.
  5. Save, Zip, and import into SF Learning
  6. Test the Search Filter in SF Learning

Note: You can only test Search Filters in SF Learning

Updating the Library Image and Styles

  1. Open any SF Learning Report Designer report
  2. Double click the PlateauThemes.rptlibrary under Resource Explorer
  3. Click Master Page tab
  4. Double click the image
  5. Select a New Image
  6. Save the Library
  7. Close the Plateau Themes library by clicking the X on the right side of the file
    name Image.png
  8. Zip the Report Designer report
  9. Check the Overwrite checkbox next to PlateauThemes when importing the Report Designer report into SF Learning
  10. Submit a ticket to Customer Support to restart the SF Learning reporting tenant

Background Colors

  1. Click the row with the background color
  2. Select Property Editor → General
  3. Write down the style (e.g. TableSectionTitleColor)
  4. Open the PlateauThemes.rptlibrary
  5. Click Outline Tab
  6. Select Themes
  7. Select Plateau_stylesheet
    Report Designer Notes
  8. Under Plateau_stylesheet find the Style you wrote down in step 3
  9. Double-Click the Style
  10. Click Background
  11. Select a new color
  12. Save the Library
  13. Upload and overwrite the Plateau Themes library in SF Learning
  14. Submit a ticket to Customer Support to restart the SF Learning reporting
    tenant

Binding Child Query to the Parent Query

  1. In the Child Data Set Query set the question mark equal to the column
    binding (e.g. SCHD_ID = ?)
  2.  In the Child Data Set define a parameter that represents the question mark
  3. Select the Child Query Table, Navigate to Properties Editor, Select Bindings,
    and click Data Set Parameter Binding button
  4. Select the column from the Parent Table to bind the parameterc

Proxy Server Settings (required for users that are behind a Proxy Server)

  1. In a text editor, open My Documents/Plateau Report Designer/PlateauReportDesigner.ini and add one of the following blocks of code.

       SSL -Dhttp.proxySet=true -Dhttps.proxyHost=[value of proxy host] -Dhttps.proxyPort=[value of proxy port]

       Non SSL -Dhttp.proxySet=true -Dhttp.proxyHost=[value of proxy host] -Dhttp.proxyPort=[value of proxy port]

       Example -Dhttp.proxySet=true -Dhttps.proxyHost=10.0.1.15 -Dhttps.proxyPort=8080

  1. Set any other properties you need to set, e.g. -Dhttp(s).nonProxyHosts, -Dhttp.proxyUser, and -Dhttp.proxyPassword
  2. Save and close the PlateauReportDesigner.ini file
  3. Restart Plateau Report Designer

Download Report Designer and find Data Source Connection Information

  1. In your staging/test instance assign the REPORT_DEVELOPER Admin Role to custom report developer admin account. If the Admin Role doesn’t exist, add a new Admin Role with the Role ID REPORT_DEVELOPER and no workflows.
  2. Login with this Admin account (note that this admin must have an Admin Role with Report workflows).
  3. Navigate to Reports and click Learning Report Designer.

Nav.png

  1. Click the Download Report Designer Button

RDC.png

  1. Enter the connection information in Report Designer Data Source and click Test Connection

Adminpassword.png

 

Specify a separate JRE to use with SF Learning Report Designer

  1. Download jre-7u80-windows-i586.tar.gz (JRE 7 32 bit).

 JAVA SE.png

  1. Unzip the file into the SF Learning Report Designer home directory (e.g. C:\Users\username\Documents\Plateau Report Designer)

jre7.png

  1. Add the following two lines to the beginning of PlateauReportDesigner.ini and then save the file
  •        -vm
  •         jre7\bin\javaw.exe

vm bin.png

  1. Start SF Learning Report Designer (it will now use the JRE located in the Report Designer Home Directory)

Keywords

SF, success factors, LMS, PRD, Report Designer Plateau , KBA , LOD-SF-LMS-PRD , Plateau Report Designer , How To

Product

SAP SuccessFactors Learning all versions