SAP Knowledge Base Article - Public

2765229 - How to Collect Email Interactions via Odata

Symptom

How to collect all the email activities from Ticket Interactions using Odata Services.

Environment

SAP Cloud for Customer

Cause

To collect all the email activities from the Interactions, a specific HTTP Method must be used.

Resolution

To collect the data, please perform the following steps:

  1. Get the Object ID of a ticket:

    HTTP Method:Get
    URL:https://<sid>-cust<client>.dev.sapbydesign.com/sap/c4c/o data/v1/c4codata/ServiceRequestCollection?$filter=ID eq '<Service Request ID>'
    Authentication:“Basic Auth”

 

  1. Use the Object ID received in the first step and call the serviceRequestInteraction:

    HTTP Method:Get
    URL:https://<sid> -cust<client>.dev.sapbydesign.com/sap/c4c/ odata/v1/c4codata/ServiceRequestInteractionCollection?$filter=ServiceRequestObjectID eq '<copied objectID'
    Authentication:“Basic Auth”

    This would return all the interactions for a particular Ticket.

Keywords

Odata; Ticket; Interactions; Emails; , KBA , LOD-CRM-SRP-INT , Ticket Interactions , How To

Product

SAP Cloud for Customer add-ins all versions