SAP Knowledge Base Article - Public

2764650 - Scheduled Job not running - no failure, not on waiting list

Symptom

The scheduled jobs or a job is not being triggered to run on the instance. There is no error (failure), job is not on the wait list it is simply never executed.

On one case the last job executed (which failed as it was interrupted by the scheduler) presented the below error message:

"Sync status from scheduler service finished successfully. And marked job status from IN_PROGRESS to FAILED to keep same status as in S2 Admin Server side."

Environment

 SAP SuccessFactors HCM Suite

Reproducing the Issue

  1. Go to Manage Scheduled Jobs on provisioning; 
  2. Check if the job that is not executing is Submitted and recurrent;
  3. Open the Monitor Jobs on provisioning;
  4. Check if the job was not executed at the time that it is scheduled;
  5. On the Monitor Jobs page, click on View Waiting Jobs;
  6. Check if the job is not on that list, if not you will need to apply the solution of this KBA.

Cause

Might be caused by an inconsistency on the background.

Resolution

The solution for this issue is to re-submit all the jobs impacted. To do so, you will need to:

  1. Cancel the current job;
  2. Edit to change the start date of the job;
  3. And re-submit the job.

The steps above will need to be done to all the impacted jobs.

Keywords

 Job Not running monitor jobs , KBA , LOD-SF-PLT-JOBS , Scheduled Jobs , Problem

Product

SAP SuccessFactors HCM Suite all versions