SAP Knowledge Base Article - Public

2731514 - PDI Extension Fields Are Not Added to Data Source During Patch Upload

Symptom

You have created a PDI solution which extends a few fields to data sources. You move this solution to your production tenant, but even though the solution is implemented and activated successfully, you see that the extension fields are missing in the data sources.

Other scenarios are possible; they have in common that analytical content which you created in your PDI solution is not successfully transferred to the target system.

Environment

  • SAP Cloud for Customer, Cloud Application Studio
  • SAP Business ByDesign, Cloud Application Studio

Reproducing the Issue

The following steps are one example of how you would notice the issue. After activating your solution in the target system:

  1. Go to the work center Business Analytics, view Design Data Sources.
  2. Search for the data source you have extended with a few PDI fields.
  3. Click on Preview.

Going through the list of characteristics and key figures, you notice that your PDI fields are not there.

Cause

The user who uploaded and activated the solution does not have the Business Analytics work center assigned.

Resolution

Please assign this work center to the user who performs such actions in your system:

  1. In C4C: Go to the Administrator work center. In ByDesign: Go to the Application and User Management work center.
  2. Open the view Business Users.
  3. Search for the respective user and click on Edit > Access Rights.
  4. Go to the Work Center and View Assignment tab.

Assign the work center Business Analytics to this user, save and upload a new version of the solution.

Keywords

PDI, Studio, Extension Field, Analytical Extension missing, data source, report, analytics , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , AP-RC-BDS , ByDesign Studio , Problem

Product

SAP Business ByDesign all versions ; SAP Cloud for Customer all versions