SAP Knowledge Base Article - Public

2730476 - CRM - Recipients Appear as Undefined in Email Campaigns - Recruiting

Symptom

As a recruiter I would like to visualize in the statistics of an email campaign the recipients. However, I see the email address set to Undefined.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

  • SuccessFactors Recruiting Managment (RCM)
  • SuccessFactors Recruiting Marketing (RMK) 

Reproducing the Issue

  1. Go to Recruiting
  2. Click on Marketing link
  3. Click on the email campaign to access all the statistics associated to the specific email
  4. Under Sent To section click on the Manually Added Recipients link
  5. A scree with title Manually Added Recipients will show-up and all the recipients listed will have no name and Email Address as Undefined

email_campaign_1.png

email_campaign_4.png

email_campaign_5.png

Cause

The recruiter doesn't have the Role-based permission to visualize the recipients.

Resolution

You need to grant OData API Candidate Export permission to the recruiter visualize the recipients in an email campaign.

In order to acomplish that go to Admin Center > Manage Permission Roles > Desired Role > Recruiting Permissions > check OData API Candidate Export and save the changes.

RBP_Permission.jpg

See Also

2651858 - Unable to Edit or Share a Talent Pool – Recruiting Management

Keywords

Recipients, Undefined, Email Campaign, Candidate Relationship Management, CRM, Recruiting Management, RCM , KBA , LOD-SF-RCM-CRM , Candidate Relationship Management , Problem

Product

SAP SuccessFactors Recruiting all versions