Symptom
In some cases, you will need to filter data in an Integration Center job, based the following:
- A standard field, that is not filterable [filterable=false]
- A custom field, that was added to a standard entity / object
Environment
- BizX
- SuccessFactors
- Integration Center
Reproducing the Issue
- Attempt to filter Integration Center output based on a non-filterable standard field (e.g. Default Locale in User)
- Attempt to filter Integration Center output based on a custom field, that was added to a standard entity / object
Cause
- Filtering data based on standard / non-filterable fields and custom fields, added to standard entities / objects is not possible.
- This is a limitation of OData which extends to Integration Center.
Resolution
There is a workaround that fulfils both of the above mentioned scenarios.
We can use the 'Calculated Filter' functionality avaliable in Integration Center to:
- Filter Integration Center output based on a non-filterable / standard field
- Filter Integration Center output based on a custom field, that was added to a standard entity / object
Taking the standard / non-filterable field 'Default Locale' from the User entity as an example:
Perform the following:
Step 1: Add the desired field to the preview in Integration Center (non-filterable / custom)
Step 2: Navigate to Filter & Sort > Advanced Filters > Calculated Filter (Button)
Step 3: Choose the IF/Then/Else operation and associate the field that we added in Step 1 - (Default Locale from User)
Step 4: Input the desired comparison & value (Default Locale from User is equal to en_GB)
Step 5: In the 'Then' step of calculation, leave field value blank (this well let the value pass through to the integration center job preview)
Step 6: In the 'Else' step of calculation, enter 'False' (this will prohibit the value from passing through to the job preview) & click 'Save
Output + Finished Calculation:
**ALL OF THE ABOVE IMAGES HAVE BEEN TAKEN FROM LOCAL SALES DEMO
**PLEASE NOTE:
- You can apply use this workaround to filter on ONE field only
- This cannot be used to filter on multiple non-filterable / custom fields
See Also
Keywords
- Filter
- Non-filterable
- Custom fields
- OData API
- Integration Center