SAP Knowledge Base Article - Public

2727149 - LinkedIn 2.0 - Widget not showing up - Recruiting Marketing

Symptom

The Linkedin widget does not show on RMK, when clicking on "Start Apply with Linkedin"

Environment

  • SuccessFactors Recruiting Marketing
  • SuccessFactors Recruiting Management  

Reproducing the Issue

  1. Access RMK site
  2. Search for any job
  3. Click on Apply Now
  4. Click on "Start apply with Linkedin"
  5. You will see that the Linkedin Widget is missing
  6. If you are reproducing this issue on Google Chrome, press F12 on the keyboard and you see the following error: Uncaught Error: Error trying to initialize the widget! Error is :origin: error.origin.not.in.api.domains  

Cause

This happens because the URL is not configured properly on Provisioning and Admin Center.

Resolution

It is necessary to correct the RMK URL in Provisioning according to the steps below:

  1. Select Recruiting Marketing Data Center URL
  2. On RMK Portal URL remove the "/" symbol at the end of the URL
  3. Click on Save

It is also necessary to correct the RMK URL in SuccessFactors instance according to the steps below:

  1. Access Admin Center
  2. Manage Data
  3. Search for LinkedInIntegrationConfiguration
  4. Click on Take Action
  5. Select Make Correction
  6. On validJsSdkDomains field, remove the "/" symbol at the end of the RMK site URL

See Also

2683467 - Apply with LinkedIn 2.0 - Recruiting

Keywords

Linkedin widget missing RMK site Uncaught Error: Error trying to initialize the widget! Error is :origin: error.origin.not.in.api.domains Linkedin 2.0 Recruiting Marketing Start apply with Linkedin , KBA , LOD-SF-RMK , Recruiting Marketing , LOD-SF-RCM , Recruiting Management , How To

Product

SAP SuccessFactors Recruiting all versions