SAP Knowledge Base Article - Public

2723405 - Unable to search Accounts using the Mail ID in Basic search

Symptom

When the Account is searched with its Mail ID in the basic search there are no results.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Customers Workcenter.
  2. Navigate to Accounts view.
  3. Enter the E-Mail ID if the Account in the basic search.
  4. You will see that there are no results even though a valid account exists.

Cause

E-Mail isn't considered during the account "basic search" (OWL and Enterprise search).

Resolution

This is the standard system behavior. The system was initially designed with a view that the communication data of the Account will be maintained in the corresponding Contact and hence a few functions might be missing.
This functionality works for Contacts, Individual Customer and Employees.

Alternatively you can use the E-Mail ID field in the Advanced filter which will give you the corresponding Account based on the E-Mail ID.

Keywords

Account, mail, search , KBA , LOD-CRM-ACC , Account , Problem

Product

SAP Cloud for Customer all versions