SAP Knowledge Base Article - Public

2719848 - Sales Quote Party Rules Not Updating Party ID for a Role

Symptom

You are working with Sales Quote Party Rules; however, for a clearly set of conditions met you are not seeing a non-unique Role being created a second time with a given Party ID.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Administrator work center.
  2. Open the Sales and Campaign Settings view.
  3. Click in the Define Rules for Sales Quote Parties hyperlink.
  4. Click in the Add Row button.
  5. Fill in the conditions in the sequence step with a Role ABC (ABC is an active Sales Quote Involved Party) and Party ID DEF (DEF is a valid Party ID to be assigned to Role ABC).
  6. Click in the Add Row button.
  7. Fill in the conditions in the sequence step with a Role ABC and Party ID GHI (GHI is a valid Party ID to be assigned to Role ABC).
  8. Go to the Sales work center.
  9. Open the Sales Quote view.
  10. Click in the New button.
  11. Fill in the information as needed to match the conditions XYZ.
  12. Click in the Save and Open button.
  13. Open the Involved Parties view.

You expected to see two instances of the role ABC, one with the Name column as DEF and the other as GHI.

Cause

ABC is a standard Sales Quote party role. Currently it is not possible to assign multiple Party IDs to a standard role using the Sales Quote Party Rules.

Resolution

You can use a z-party role for achieving this. For z-parties it is possible to assign Party IDs to multiple instances of a role inside a Sales Quote using Sales Quote Party Rules. If necessary, via a custom implementation (PDI) you could copy the z-parties to the standard parties.

This is the standard behavior of the system.

If you need this functionality urgently you may contact your implementation manager to help with such request or approach directly the SAP Cloud Service Center.
You can find more details about the services offered by Cloud Service Center on https://www.sap.com/services/application-development.html . You can contact Cloud Service Center as follows:
1. If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder
2. If you are a customer: please use the little blue box “Contact Us” shown on the very right hand side of https://www.sap.com/services/application-development.html, choose “Contact Us”, choose “Services”, choose “SAP Custom Development” and complete the page

Note: The services of the SAP Cloud Service Center will be charged as packaged services based on fixed prices.

An alternative option may be to check the SAP Customer Influencer Site to submit an idea: https://influence.sap.com/SAPCloudforCustomer

Keywords

Sales Quote ; Sales Quote Party Rules ; Standard Involved Party ; Update Role ; Party ID ; , KBA , LOD-LE-CQP , Customer Quote Processing , How To

Product

SAP Cloud for Customer all versions