SAP Knowledge Base Article - Public

2719546 - Field Values are not displaying in the Custom Data Source Report

Symptom

The field values are displaying as # when you are executing a report created from a custom data source, from Business Analytics work center.

Environment

SAP Cloud Application Studio

SAP Business ByDesign

SAP CLoud for Customer

Reproducing the Issue

  1. Go to Business Analytics Workcenter.
  2. Go to Design Reports View.
  3. Choose the Report which you have created.
  4. Provide the values in the Selection.
  5. Click on Go.
  6. You can see # under all the field columns.

Cause

This is because you have made a setting not to show real data to key user. If the user does not choose to Show Real Data, it is expected behavior that the report data will not be available.

Resolution

You can check and change the same by following the steps given below.

  1. Go the Business Configuration Workcenter.
  2. Go to Overview
  3. Under Business Configuration Search, Search for Administrator Analytics.
  4. Under the Type Activity you will get the configuration element Administrator Analytics - Settings. Click on it.
  5. Under the title Real Data Shown to Key User Instead of Generic Data, you will see a check box Show Real Data.
  6. The check box will not be checked.
  7. You can select the check box and Save.

See Also

2679556 - Data Source Preview is not supported in Business Analytics

Keywords

No data executing custom report Custom data source report not working Note that only generated test data is displayed , KBA , show real data , dummy data is displayed , AP-RC-BDS-ANA , ByDesign Studio Analytics , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , Problem

Product

SAP Business ByDesign all versions ; SAP Cloud for Customer all versions