SAP Knowledge Base Article - Public

2718823 - Using The Created By Field Within a Workflow Rule

Symptom

You have created a workflow rule using the Created By field and matched it against the Technical User.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Administrator work center.
  2. Go to the Workflow Rules view.
  3. Click on New.
  4. Enter Basic Data.
  5. Define Condition using Created By field and Technical User as reference.
  6. Define Actions.
  7. Activate workflow rule.
  8. Workflow rule is not being triggered for the Technical User reference.

Cause

The field Created By is bind to path \CREATION_IDENTITY\PERSON\CURRENT_COMMON.

Resolution

For evaluation of condition based on field Created By a business partner instance should be present.

If you consider this to be changed within the system, we would like to kindly ask you to post this idea in the forum (please go to 'Help' at the top of the screen and choose ''Make SAP Cloud for Customer Better'' - https://influence.sap.com/SAPCloudforCustomer).

Keywords

Workflow Rule, Technical User, Business Partner , KBA , workflow rule , technical user , business partner , LOD-CRM-WKF , Workflow , How To

Product

SAP Cloud for Customer all versions