SAP Knowledge Base Article - Public

2715999 - You Are Not Able to Complete a Survey From an Opportunity in Responsive UI

Symptom

You are trying to set a Survey to Completed in the Responsive UI from an Opportunity.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Log in the system using Responsive UI.
  2. Go to the Sales work center.
  3. Open the Opportunity XYZ (XYZ represents the ID of the Opportunity).
  4. Go to the Surveys facet.
  5. Fill out any survey.
  6. Result: There is no option to complete the Survey from an Opportunity. The survey stays editable. 

Cause

Currently the only way to complete the Survey is by filling the Survey and submitting it. It will stay editable until the end of life cycle of that object.

This also applies for Leads and Visits.

The IsEditable flag is depended on the Approval Status, InformationLifeCycleStatusCode. By changing the opportunity to Won you change the LifeCycleStatusCode not the InformationLifeCycleStatusCode. Meaning, setting the opportunity to won or lost will not end the editable cycle of the object and therefore not of the survey, either. 
 
The InformationLifeCycleStatusCode changes when you depersonalize the opportunity. The Approval Status changes when the opportunity is submitted for approval or was approved.

Resolution

If you need this functionality urgently you may contact your implementation manager to help with such request or approach directly the SAP Cloud Service Center.

You can find more details about the services offered by Cloud Service Center on https://www.sap.com/services/application-development.html . You can contact Cloud Service Center as follows:


1. If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder.
2. If you are a customer: please use the little blue box “Contact Us” shown on the very right-hand side of https://www.sap.com/services/application-development.html, choose “Contact Us”, choose “Services”, choose “SAP Custom Development” and complete the page.


Note: The services of the SAP Cloud Service Center will be charged as packaged services based on fixed prices.

An alternative option may be to check the SAP Customer Influencer Site to submit an idea: https://influence.sap.com/SAPCloudforCustomer.

Keywords

Responsive UI ; Survey ; Opportunity ; Leads; Visits , KBA , LOD-CRM-OPP , Opportunity Management , LOD-CRM-LM , Lead Management , LOD-LE-SUR-EXE , Survey execution = runtime , How To

Product

SAP Cloud for Customer add-ins all versions