SAP Knowledge Base Article - Public

2709608 - Runtime Filters not showing all data - Reporting Filters

Symptom

When trying to filter a report, the runtime filters do not show all data available at the tables.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors Workforce Analytics
  • Adhoc Reporting
  • Advanced Reporting

Reproducing the Issue

  1. Open an existing report that has Runtime Filters applied on it
  2. When adding a filter by using the Runtime Filter, you will notice that Data is missing from the Report Values, not showing all the object values.

Cause

The report has Static Filters applied, which prevents the full information to be shown. When running a report that has Static Filters, when applying the Runtime Filter it will only show information that will be visible with the added Static Filters.

Resolution

In order to view all the information related to the specific object when filtering it by the Runtime Filter, you will need to remove the Static Filter from the Report, since the Runtime Filter will only show information from the Static Filter.

Report Runtime Filter information with Static Filter:

D24E4FE5.PNG

Report Runtime Filter information without Static Filter:

E139DA74.PNG

See Also

2456591 - ORD - runtime filter does not select target report value correctly - no filter is applied
2549528 - Runtime filter and Person Context - ORD
2531743 - Adhoc Report returns more results than expected - using runtime filter

Keywords

Analytics Runtime Filter Static Filter Not Showing Data , KBA , LOD-SF-ANA , Analytics & Reporting (Ad Hoc, ORD) , LOD-SF-ANA-ADH , Adhoc Reports & Report Builder , LOD-SF-ANA-ODS , Advanced Reporting , Problem

Product

SAP SuccessFactors HCM Suite all versions ; SAP SuccessFactors Workforce Analytics all versions