SAP Knowledge Base Article - Public

2707848 - How to add different types of Mashups in Cloud for Customer

Symptom

You have created and activated a Mashup but are not able add it to a particular screen

Environment

Cloud for Customer

Reproducing the Issue

1. Create and activate the required Mashup.

2. Go to the respective screen to add the Mashup.

3. Go to Adapt and select Edit Master Layout.

4. Hover over a part of the screen and from the option menu select Add Items and then select Add Mashups.

5. You are not able to find your Mashup on the Add Mashup screen.

Cause

Different types of Mashups such  as HTML Mashups, URL Mashups etc. can be added by hovering over specific parts of the screen

Resolution

Please refer the below information about how to add different types of Mashups

1) URL Mashups: These Mashups can be added at Section Group Level, to go to Section Group Level hover over a field and click on Add Items ( + icon), you will see 3 options: Add Fields, Add Mashup and Add Section.

URL mashup1.PNG

2) HTML Mashups: These Masups can be added at Pane Level, to go to Pane Level, hover over a field or a table column and click on Select Parent, on clicking Add Items ( + icon) at Pane Level you will find 2 options: Add Fields and Add Mashups.

HTMLMashup1.PNG

3) Data Mashups: These Mashups can be added at Section Group Level ( like URL Mashups ) and at View Anchor level, to go to View Anchor Level hover over a field and continue selecting parent until you reach the top of the screen, on clicking Add Items ( + icon) at View Anchor level you will find 2 oprtions: Add Embedded Reports and Add Mashups.

Data Mashup 1.PNG

 

Keywords

not able to add mashup, add mashup, not able to find mashup, find mashup , KBA , AP-RC-GEN-MSH , Mashups , Problem

Product

SAP Cloud for Customer all versions