Symptom
Customer has done proxy assignments in the system. When performing an employee import with the column 'Proxy' blank, it is resetting all the user's proxy assignments.
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
- Do proxy assignments in the system using Proxy Management or Proxy Import
- Go to Admin Center > Update User Information > Employee Import
- Download the data import file template
- Fill out the file with the user information and let the column Proxy blank
- Import this file to the system
- Notice that the users lost the proxy rights granted before
Cause
The column 'Proxy' in the User Data File updates all the proxy assignments done for that specific user. If the user used to have proxy rights and you are trying to import without data in this column, the system will reset all the proxy rights.
Resolution
In case you don't want to control the proxy assignments through Employee Import, you can remove this column from the UDF. Please contact your implementation partner or open an case to SuccessFactors Cloud Product Support requesting to remove it in the Data Model.
After removing the column, please make sure to update the files you are using to import either manually or through scheduled jobs.
See Also
2087504 - Data Imports & Exports - Explanation of the Fields in the Employee Import File: User Import File
3390669 - Deleting proxy assignments for inactive users via proxy import failing with "user not in proxy's domain". - SAP for Me
2524310 - Proxy Import Feature | How to enable, grant access and use - SAP for Me
Keywords
Proxy, Reset, Employee Import, UDF, User Data File, overwriting, overwrite, proxy permission are not available, missing , KBA , LOD-SF-PLT-PRX , Proxy , LOD-SF-PLT-UIM , Employee Import Issues , How To