SAP Knowledge Base Article - Public

2698630 - Terminated users with pending Job Requisitions or Offer Approvals - Recruiting Management

Symptom

A user that is part of an approval pipeline (either Job Requisition or Offer) is terminated and now, it is no longer possible to proceed with the document/form approval pipeline.

Environment

SuccessFactors Recruiting Management - All versions

Cause

There is currently no system validation that denies a user purge, if this user is tied to any document approval. If we delete a user under this condition, it will be needed to work around the approval process.

Resolution

Please, have in mind that the just deleted user will not be able to approve any document, as well as it will not be possible to have any approval routed to other (active) user, while the just deleted user is still inactive. Considering this, there are 3 possible solutions for this issue:

  • The most recommended approach would be reactivating the just deleted user for a short period. With this user active once again, we may have the pending approval routed to another user or we may just approve/decline the referred form. After whichever action is taken, we may terminate the user again. This should take no longer than 5 minutes to be performed and requires no action from Support.
  • It is also possible to run an Operations script that will have the form approver changed, from the purged one to one that is still active. This requires Support assistance and usually takes about 2 weeks to be concluded.
  • If none of the above alternatives are acceptable as per the client internal business/processes, it is still possible to have a brand new Job Requisition created (that could also be ONLY internally posted), so we may have a new approval pipeline set or have a candidate "re-applying" to it and have a new offer (also, with another approval pipeline set) sent to him/her.

Based on these 3 possible approaches, please understand such issues will not be handled as very high priority incidents. As per Support Incident Prioritization Guidelines, scenarios that have one or more work arounds do not qualify as Very High priority, considering there are still ways to proceed using the system, if we just change a little bit the way we are going to use the tool.

Keywords

Purged user Deleted user Terminated user Inactive user Approval pipeline , KBA , LOD-SF-RCM , Recruiting Management , How To

Product

SAP SuccessFactors Recruiting all versions