SAP Knowledge Base Article - Public

2694319 - Unable to import quiz because its status is published

Symptom

When trying to import a quiz, the background job fails and message stating the error says: "Cannot add Question since the Quiz is Published.".

Environment

SAP SuccessFactors Learning Management System (LMS)

Reproducing the Issue

In the LMS admin side, click on:

  1. System Admin > Tools > Import Data >
  2. Select "Import Data" in the Action radio button > From the "Record Type" dropdown, select "Quiz" > Add the file through the "Import File" option > If applicable, select the desired time zone in the "Time Zone ID" > Submit >
  3. Schedule the Background Job > Finish > Its status shows "Failed" >
  4. Download the unsuccessful file from the "Import Results" list, "Download" option (System Admin > Tools > Import Data) >
  5. The "Comment" column, in the "Questions" tab, says "Cannot add Question since the Quiz is Published.".

Cause

The cause, as stated in the "Comment" column, is due to quiz be published.

Resolution

In the LMS admin side, click on:

  1. Content > Assessments > Search for the desired quiz and access it >
  2. Unpublish it clicking on the button from the "Published" column > Confirm clicking on "Yes".

See Also

2442307 - Cannot delete a question from a quiz

Keywords

add, upload, quiz, published, failed, background, job , KBA , LOD-SF-LMS , SuccessFactors Learning , LOD-SF-LMS-ASB , Assessment Builder , Problem

Product

SAP SuccessFactors Learning all versions